Herbers Excel-Forum - das Archiv

zählenwenn

Bild

Betrifft: zählenwenn
von: Metin

Geschrieben am: 29.12.2006 15:01:55
Hallo Excel-Gemeinde
hätte mal wieder ein kleines Problem
Habe 13 Blätter in einer Arbeitsmappe
Blätter Januar bis Dezember und Statistik.
in den Blättern Januar - Dezember kommen im Bereich A27:M44
Werte vor als Bsp. 123
Im Blatt Statistik soll als Bsp. in Zelle A1 zusammengezählt
werden wie oft der Wert 123 in den zwölf Blättern davor vorkommt.
danke im voraus
Bild

Betrifft: AW: zählenwenn
von: Heinz H

Geschrieben am: 29.12.2006 16:09:12
Hallo Metin
Mache zB. in B50 eines jeden Tab.Blatt die Formel =ZÄHLENWENN(A5:M44;123)
Und in einem Hilfsblatt =SUMME(Tabelle13:Tabelle1!B50)
So müsste es funktionieren.
Gruß Heinz
Tabelle4
 B
451
46 
47 
48 
49 
501
Formeln der Tabelle
B45 : =SUMME(Tabelle3:Tabelle1!B50)
B50 : =ZÄHLENWENN(A5:M44;123)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bild

Betrifft: AW: zählenwenn
von: Metin

Geschrieben am: 29.12.2006 16:57:29
Hallo Heinz
danke für die Antwort, aber gibt es noch eine andere
Möglichkeit. Ich dachte eher das eine Formel in der Ausgabezelle
eingegeben wird.
als Bsp. =zählenwenn(Januar:Dezember!A27:M44;123)
das Funktioniert nur nicht es kommt der Fehler #WERT!
gruß Metin
Bild

Betrifft: AW: zählenwenn
von: Metin
Geschrieben am: 29.12.2006 17:37:52
Kann man eventuell die folgende Formel verkürzen
=SUMME(ZÄHLENWENN(Januar!A27:M44;123)+ZÄHLENWENN(Februar!A27:M44;123)+ZÄHLENWENN(März!A27:M44;123)...usw. bis Dezember!A27:M44;123)
gruß Metin
Bild

Betrifft: ZÄHLENWENN mit Monatsarray
von: {Boris}
Geschrieben am: 29.12.2006 17:49:54
Hi Metin,
=SUMMENPRODUKT(ZÄHLENWENN(INDIREKT(TEXT("1."&ZEILE($1:$12);"MMMM")&"!A27:M44");123))
Grüße Boris
Bild

Betrifft: klappt super danke
von: Metin
Geschrieben am: 29.12.2006 18:26:00
Danke und guten Rutsch an alle
 Bild