Herbers Excel-Forum - das Archiv

ZÄHLENWENN DANN Formel? mit 2suchkriterien

Bild

Betrifft: ZÄHLENWENN DANN Formel? mit 2suchkriterien
von: P

Geschrieben am: 04.01.2007 11:43:00
Hallo!
Folg. Problem:
Ich will in einer Spalte in der verschiedene Altersstufen angegeben sind, abfragen, wieviel von 15-18 in der Spalte sind, wieviel von 19-22, 23-26, 27-30 und wer Älter ist als 30.
Die Abfrage für 15-18 hab ich mit folgender Formel hinbekommen:
=ZÄHLENWENN(Datenblatt!C10:C59;"<=18")
auch die mit Älter als 30:
=ZÄHLENWENN(Datenblatt!C10:C59;">30")
nur bei den zwischen wo ich mit 2 Suchbedingungen kämpfen mus haut das nicht hin, dass er mir die Anzahl ausspuckt wieviel zwischen 19 und 22 in der Spalte eingegebn wurde!
Zur Verdeutlichung, hier die Tabelle mit Formeln
SPALTE A SPALTE B
Alter der Kunden: Formel:
15-18 Jahre =ZÄHLENWENN(Datenblatt!C10:C59;"<=18")
19-22 Jahre ?
23-26 Jahre ?
27-30 Jahre ?
älter als 30 Jahre =ZÄHLENWENN(Datenblatt!C10:C59;">30")
Bild

Betrifft: AW: ZÄHLENWENN DANN Formel? mit 2suchkriterien
von: Sinan

Geschrieben am: 04.01.2007 12:05:11
Hallo P,
man kann das Ganze mittels der Formel "UND" bzw. "WENN" lösen, die elegantere Variante ist aber die ARRAY-Formel "Häufigkeit". Anbei eine Beispiel-Datei, in der alle Schritte zum Selbermachen stehen (https://www.herber.de/bbs/user/39363.xls).
Feedback wäre klasse!
Viele Grüße
Sinan
Bild

Betrifft: AW: ZÄHLENWENN DANN Formel? mit 2suchkriterien
von: P

Geschrieben am: 04.01.2007 13:44:49
@Sinan: Das mit den Array-Formeln ist schon super; Danke.
Nun noch ein kleines Problem, in meiner Excel Tabelle möchte ich aber die Alter nicht einzeln abfragen sondern nur wissen, wieviel zwischen 15-18 Jahren sind, zwischen 19-22 Jahren, usw. wie funzt. das? und den Altersdurchschnitt.
Vorab schon mal vielen Dank
P.
Bild

Betrifft: AW: ZÄHLENWENN DANN Formel? mit 2suchkriterien
von: Bertram

Geschrieben am: 04.01.2007 14:19:22
Hi P,
kleiner 18: =COUNTIF($C$10:$C$59;"<=18")
19-22: =COUNT($C$10:$C$59)-COUNTIF($C$10:$C$59;"<19")-COUNTIF($C$10:$C$59;">22")
23-26: =COUNT($C$10:$C$59)-COUNTIF($C$10:$C$59;"<23")-COUNTIF($C$10:$C$59;">26")
28-30: =COUNT($C$10:$C$59)-COUNTIF($C$10:$C$59;"<27")-COUNTIF($C$10:$C$59;">30")
größer 30: =COUNTIF($C$10:$C$59;">30")
Gruß
Bertram
Bild

Betrifft: AW: ZÄHLENWENN DANN Formel? mit 2suchkriterien
von: Sinan

Geschrieben am: 04.01.2007 14:48:01
Hi P,
verstehe leider nicht ganz genau was Du meinst, vielleicht schickst Du mir einfach mal Deine Datei und erklärst mir welches Ergebnis Du verfolgst.
Wenn Du den Altersdurchschnitt berechnen willst, hast Du grundsätzlich 2 Möglichkeiten: Entweder Du machst das über Deine Urliste (Die Spalte, die die Altersdaten enthält; in meiner Datei war das die Spalte A), oder Du machst das über die klassierten Daten, wobei diese Mittelwertberechnung ungenauer wird, da Du hier von der Klassenmitte ausgehen musst. Da ich aber nicht weiß, was Du genau berechnen willst (Mittelwert aller Daten oder nur die Mittelwerte der klassierten oder Mittelwert aller klassierten Daten) schickst Du mir am Besten einfach mal Deine Datei.
Viele Grüße
Sinan
Bild

Betrifft: summenprodukt()
von: heikoS
Geschrieben am: 04.01.2007 14:18:08
Hallo ???,
ich würd´s so lösen:
=summenprodukt(--(Datenblatt!$C$10:$C$59>=19);--(Datenblatt!$C$10:$C$59<=22))
Klappt´s?
Gruß Heiko
Bild

Betrifft: AW: summenprodukt()
von: P
Geschrieben am: 04.01.2007 14:38:13
Hallo Heiko!
Ja ich habs über das Summenprodukt gelöst. Bis auf die Abstände 15-18 und älter als 30 habe ich wie schon von Anfang an bei ZÄHLENWENN... belassen.
Vielen Dank für die zahlreichen Antworten !!!
P.
Bild

Betrifft: Bitte, danke für Deine Rückmeldung! oT
von: heikoS
Geschrieben am: 04.01.2007 14:59:48
 Bild
Excel-Beispiele zum Thema "ZÄHLENWENN DANN Formel? mit 2suchkriterien"
Anzeigen von Werten und Formeln Zeile einfügen und Formeln und Werte übernehmen
Formeln mit Zelladressen speichern Zeilenumbruch in Formel erzwingen
Aktueller Arbeitsblattname in Formel Variable in Formel einbauen
Ein Zeichen in einer Formel suchen Variable in Excel-Formel einbauen.
Summenformel unter Zahlenreihe eintragen Arbeitszeittabelle und SVERWEIS-Formel