Herbers Excel-Forum - das Archiv

2 Tabellen vergleichen, dann sortieren

Bild

Betrifft: 2 Tabellen vergleichen, dann sortieren
von: Chris

Geschrieben am: 04.01.2007 14:23:52
Hallo liebes Excel Forum!
ich habe 2 listen in excel.
Beide listen haben die gleichen Produkte.
Liste 1:
hat über 1000 Produkte
Spalte 1 sind die Produktnamen drin, und in der Spalte 2 sind die Produktnummern
Liste 2:
besteht aus den gleichen Produkten wie Liste 1, hat jedoch eine andere Sortierung und diese muß beibehalten werden.
Was ich brauch ist, das Liste 2 die Produktnummern bekommt von Liste 1, ohne das die Sortierung von Liste 2 sich verändert. Sprich es müßte eine Lösung geben das ich Liste 1 & 2 vergleiche, und jedesmal wenn das script ein gleichen Artikel findet, dann die Produktnummer kopiert von das Produkt was gleich ist.
Gibt es da ein Weg, wie kann ich das in Excel lösen ?
Vielen Dank im voraus auf eure Antworten!
Gruß, der Chris.
Bild

Betrifft: AW: 2 Tabellen vergleichen, dann sortieren
von: fcs

Geschrieben am: 04.01.2007 15:10:57
Hallo Chris,
öffne die Dateien beider Listen und verwende die Funktion SVERWEIS in Tabelle 2 um die Produktnummern einzulesen:
Beispiel für Zelle B2
=SVERWEIS(A2;[Liste1.xls]Tabelle1!$A$1:$B$1000;2;WAHR)
Falls die beiden Listen in der gleichen Datei sind entfällt der Teil "[Liste1.xls]" für den Dateinamen. Anschließend kopierst du die Formel in Liste 2 für alle Produktnamen. Dann markierst du die Spalte mit den berechneten Produktnummern, kopierst sie und fügst sie an der gleichen Position als Werte wieder ein. Gruß Franz
Bild

Betrifft: AW: 2 Tabellen vergleichen, dann sortieren
von: Daniel Eisert

Geschrieben am: 04.01.2007 15:17:22
Hallo
klassischer Fall für den SVERWEIS.
in Tabelle2 Spalte einfügen mit folgender Formel:
=Sverweis(A1;Tabelle1!$A$1:$B$1000;2;0)
Bezeichnungen und Bereiche natürlich noch entsprechend anpassen.
Gruß, Daniel
 Bild
Excel-Beispiele zum Thema "2 Tabellen vergleichen, dann sortieren"
Suche über mehrere Tabellen Benennen von Tabellenblättern mit Monatsnamen
Druckseitenlinien im Tabellenblatt Tabellenblattnamen in ein Listenfeld einlesen
Suchbegriff über mehrere Tabellenblätter suchen. Tabellenblätter benennen
Tabellenblatt auswählen Zustand von Tabellenblatt-Checkboxes ermitteln
Tabellenblattnamen der VBE-Projekte ändern Tabellenblattnamen nach Datum