Herbers Excel-Forum - das Archiv

Sortieren-Suche-IndexFormel

Bild

Betrifft: Sortieren-Suche-IndexFormel
von: Ernst

Geschrieben am: 08.01.2007 16:22:13
Hallo sehr geehrtes Forum,
Hallo Profis,
Ich brauechte Hilfe bei einer INDEX Formel (siehe upload-file)
https://www.herber.de/bbs/user/39485.xls
Die Index Formel habe ich mir aus dem Forum geholt und mir fuer meine Zwecke zurechtgestrickt, damit ich nach dem Kriterium (gelbe Zelle) sortieren kann.
Meine Frage ist nun:
Funktioniert die INDEX Formel auch wenn ich die Daten (Spalte A,B,C,D und E) in einem anderen (externen) Excel-Datei stehen habe und hier allerdings in der ersten Zeile eine Ueberschrift (Spaltenbeschriftung) stehen habe?
Wenn ich in meiner Datei eine Zeile ueber den Daten einfuege bekomme ich die Fehlermeldung #ZAHL! bei einigen Zellen aus dem Bereich F:I
Wie muss ich meine Formel abwandeln?
Vielen Dank fuer die Hilfe
LG
Ernst
Bild

Betrifft: INDEX-Formel ab Zeile 2
von: WF

Geschrieben am: 08.01.2007 20:18:06
Hi Ernst,
das geht viel einfacher und ZEILE(von:bis) muß mit 1 beginnen.
In F2 die Arrayformel:
=WENN(ZEILE(A1)>ZÄHLENWENN(E:E;M$21);"";KKLEINSTE(WENN(E$2:E$100=M$21;ZEILE($1:$99));ZEILE(A1)))}
in G2:
=WENN(F2="";"";INDEX(B:B;VERGLEICH(F2;A:A;0)))
analog H2 sowie i2
F2 bis i2 runterkopieren
ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.
trapp, trapp, trapp, trapp, trapp, brrrrr
WF
http://www.excelformeln.de/
die ultimative Formelseite
Bild

Betrifft: AW: INDEX-Formel ab Zeile 2
von: Ernst

Geschrieben am: 08.01.2007 21:22:00
Hallo WF,
vielen Dank fuer Deine Info
irgendwie klappt's noch nicht ganz.
Habe in meiner Datei eine neue Zeile ganz am Anfang (A) eingefügt und danach in F2
Deine Formel kopiert und mit (ARRAY Formel)Strg/Shift Enter eingegeben
Es kam aber dann #NAME?
Was bedeutet eigentlich die drei Zeichen nach Zeile(A1) "& g t" .. das hab ich ja noch nirgends gesehen.
Kannst Du mir nochmals helfen?
Danke und Gruss
Ernst
Bild

Betrifft: da stimmt was bei Deiner Darstellung nicht
von: WF

Geschrieben am: 08.01.2007 21:51:34
"Was bedeutet eigentlich die drei Zeichen nach Zeile(A1) "& g t" .. das hab ich ja noch nirgends gesehen."
. nach ZEILE(A1) folgen 3Klammern: ))}
{=WENN(ZEILE(A1)>ZÄHLENWENN(E:E;M$21);"";KKLEINSTE(WENN(E$2:E$100=M$21;ZEILE($1:$99));ZEILE(A1)))}
???
WF
Bild

Betrifft: AW: da stimmt was bei Deiner Darstellung nicht
von: Ernst

Geschrieben am: 08.01.2007 22:46:25
Hallo WF,
habe folgende Formel eingegeben (Deine kopiert mit Ersatz eines = anstatt des "& g t"
{=WENN(ZEILE(A1)=ZÄHLENWENN(E:E;M$21);"";KKLEINSTE(WENN(E$2:E$100=M$21;ZEILE($1:$99));ZEILE(A1)))}
die {} am Anfang und Ende fuer Array-Formel natürlich mit Strg Shift Enter gemacht
danach die Formel runtergezogen
Kannst Du mir bitte nochmals in ein paar Worten beschreiben was hinter dem ersten Mal Zeile(A1) reinkommt? stimmt das "Ist gleich"?
Funzt noch nicht ganz.
Vielen Dank nochmals
LG
Ernst
Bild

Betrifft: WF meint > ! Auch er scheint die HTML-Codes...
von: Luc:-?
Geschrieben am: 09.01.2007 01:27:28
...nicht richtig zu beherrschen, Ernst, ;-)
sonst wäre ihm das sicher aufgefallen. Oder er hat einen Browser, der das merkwürdigerweise toleriert. Man schreibt & gt ; (ohne Leerzeichen) → > (greater than).
Gruß Luc :-?
Bild

Betrifft: AW: WF meint > ! Auch er scheint die HTML-Codes...
von: Ernst
Geschrieben am: 11.01.2007 21:54:29
Hallo Luc,
Hallo WF,
jetzt klappts !!!!
habs kapiert & gt soll also heissen "groesser als" oder "Spitze Klammer zu"
sprich ">"
Vielen Dank fuer eure Hilfe
Gruss
Ernst
Bild

Betrifft: AW: Na also! - Gruß owT
von: Luc:-?
Geschrieben am: 13.01.2007 02:03:38
:-?
 Bild