Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
904to908
904to908
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Problem mit ist wenn Funktion!

Problem mit ist wenn Funktion!
06.09.2007 23:14:38
Werner
Hallo Leute, bräuchte hilfe eines Excel-Profis!
Folgendes,ich bin gerade dabei ein Abrechnungsprogramm zu erstellen.
In einem Feld (C12) kommt ein Wert an, der mittels einer "ist wenn Formel" weiterverarbeitet werden soll.
Zu diesem Feld wird ein Maximalwert festgelegt, sagen wir z.B. 8.
Die Formel gliedert sich in 3 Teile.
Bis 8, genau 8, über 8.
Die Formel funktioniert soweit ganz gut, nur wenn sich der Wert 8 einmal ändern sollte, gibt es eine riesige Umbauaktion. Daher wäre es besser, wenn nicht mit dem starren Wert 8 gearbeitet würde, sondern nur auf ein Bezugsfeld zugegriffen würde und alle Felder automatisch dann mitgehen.
Bloß stehe ich gerade voll im Excel-Nirwana, komme einfach nicht dahinter, wie ich die Formel umbauen soll.
Vielleicht weis einer von euch, wie ich das lösen könnte!
Hier mal die Formel in starrer Ausführung!
=Wenn(C128;"8")))
Auf Deutsch hiese es wohl:
Wenn Wert unter 8 einfach direkt übernehmen, wenn Wert genau 8 dann eine 8 übernehmen, wenn Wert über 8 eine 8 übernehmen!
Zielsetzung wäre, das die 8 ersetzt wird auf den Wert im Bezugsfeld E3 (Beispiel).
In diesem Feld kann dann z.B. 5,6,7,9 usw. stehen.
Schreibe ich jeweils statt der 8 nur E3 rein geht das so noch nicht, er soll ja den Wert in E3 nehmen!
Bitte helft mir, bin kurz vorm Verzweifeln!
Bin für jeden Tip dankbar!
Gruß Werner

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Problem mit ist wenn Funktion!
06.09.2007 23:19:57
Josef
Hallo Werner,
warum einfach, wenn's auch kompliziert geht;-))
Tabelle3

 BCDE
7    
8 77 
9 88 
10 98 
11    

Formeln der Tabelle
ZelleFormel
D8=MIN(C8;8)
D9=MIN(C9;8)
D10=MIN(C10;8)
Excel Tabellen im Web darstellen  Excel Jeanie HTML
Gruß Sepp

Anzeige
AW: Problem mit ist wenn Funktion!
06.09.2007 23:22:00
Josef
Hallo Werner,
oder mit Bezug auf "E3".
Tabelle3

 BCDEFG
2      
3   8  
4      
5      
6      
7      
8 77   
9 88   
10 98   
11      

Formeln der Tabelle
ZelleFormel
D8=MIN(C8;$E$3)
D9=MIN(C9;$E$3)
D10=MIN(C10;$E$3)
Excel Tabellen im Web darstellen  Excel Jeanie HTML
Gruß Sepp

Anzeige
AW: Problem mit ist wenn Funktion!
06.09.2007 23:30:00
jockel
hi Werner, meinst du so:
Tabelle1
 BCDE
3   8
4    
5    
6    
7    
8    
9    
10    
11    
1233 8
Formeln der Tabelle
B12 : =WENN(C12>=E12;E12;C12)
E12 : =E3
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Tabelle1
 BCDE
3   8
4    
5    
6    
7    
8    
9    
10    
11    
12810 8
Formeln der Tabelle
B12 : =WENN(C12>=E12;E12;C12)
E12 : =E3
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Tabelle1
 BCDE
3   8
4    
5    
6    
7    
8    
9    
10    
11    
1288 8
Formeln der Tabelle
B12 : =WENN(C12>=E12;E12;C12)
E12 : =E3
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Tabelle1
 BCDE
3   6
4    
5    
6    
7    
8    
9    
10    
11    
1269 6
Formeln der Tabelle
B12 : =WENN(C12>=E12;E12;C12)
E12 : =E3
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
cu jörg
ein feedback wär ganz reizend

Anzeige
AW: Problem mit ist wenn Funktion!
08.09.2007 11:56:50
Werner
Hallo Sepp, Jörg, Jockel und Josef Ehrensberger!
Vielen Dank für eure tollen Vorschläge, funktioniert ganz toll!
War ganz erstaunt, das die Antworten so schnell und konkret kamen, echt stark!
- - - D A N K E - - - D A N K E - - - D A N K E - - - D A N K E - - - D A N K E - - - D A N K E - - - D A N K E

327 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige