Microsoft Excel

Herbers Excel/VBA-Archiv

Wert auf best. Nachkommastellen ändern

Betrifft: Wert auf best. Nachkommastellen ändern von: Hermann
Geschrieben am: 04.10.2007 16:36:19

Hallo,
ich möchte die Werte in unterschiedlichen Zellen auf 3 Nachkommastellen vergleichen nach der Formel

=WENN(A1=B1;1;0)

z.B. sollen die Werte A1=0,93 und B1=0,92999999 den Wert 1 zurückgeben, da auf 3 Nachkommastellen gerundet A1=B1=0,930 gilt.

Nun haben die Werte aber verschiedenen Ursprung und damit verschiedenes Format.

Formatierung, die Funktion Runden und kopieren der gerundeten Werte habe ich probiert, aber ohne Erfolg. Es werden immer die ursprünglichen Werte bei der Wenn-Funktion verglichen und führen zum falschen Ergebnis (=0).

Schon mal vielen Dank für Eure Hilfe.
Gruß
Hermann

  

Betrifft: AW: Wert auf best. Nachkommastellen ändern von: Hajo_Zi
Geschrieben am: 04.10.2007 16:41:33

Hallo Hermann,

falls ein Zahl gerundet wird sind nicht mehr alle Kommastellen vorhanden.

0,92999999999999999999999 ergibt bei runden auf 2 Stellen 0,93

GrußformelHomepage


  

Betrifft: AW: Wert auf best. Nachkommastellen ändern von: Hermann
Geschrieben am: 04.10.2007 16:58:40

Hallo Hajo,

...ja man muß schon beide Zellen runden und nicht vorraussetzen daß 0,93 = 0,930 ist ;-)

Danke für Deine Hilfe

Gruß
Hermann



  

Betrifft: AW: Wert auf best. Nachkommastellen ändern von: Tino
Geschrieben am: 04.10.2007 16:45:50

Hallo,

=WENN(RECHTS(RUNDEN(A1;3);3)=RECHTS(RUNDEN(B1;3);3);1;0)



Gruss
Tino


  

Betrifft: AW: Wert auf best. Nachkommastellen ändern von: Hermann
Geschrieben am: 04.10.2007 17:03:17

Hallo Tino,

mit der Runden-Formel in der WENN Abfrage ist ja nochmal eleganter als noch mal die ganzen Zellen zuvor zu runden.

Danke
Gruß
Hermann


  

Betrifft: AW: Wert auf best. Nachkommastellen ändern von: Tino
Geschrieben am: 04.10.2007 17:52:01

Hallo,
eine weitere möglichkeit sehe ich in dieser Formel.

=WENN(G4-ABRUNDEN(A1;0)=H4-ABRUNDEN(B1;0);1;0)



Gruss
Tino


  

Betrifft: Sorry Fehler eingeschlichen von: Tino
Geschrieben am: 04.10.2007 17:56:37

Hallo,
hat sich doch ein Fehler eingeschlichen!

=WENN(A1-ABRUNDEN(A1;0)=B1-ABRUNDEN(B1;0);1;0)




Sorry
Gruss
Tino