Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Zellwert per Zufall uebertragen!

Betrifft: Zellwert per Zufall uebertragen! von: René
Geschrieben am: 08.10.2007 15:48:08

Hi Gemeinde,

dieses Vorhaben wird vermutlich nur mit einem Makro gelingen (geh zumindest davon aus)
Folgend stellt sich mein Problem dar:
In Zelle N1 steht als Wert A1, in O1 steht B1, P1 steht A2, Q1 B2, R1 A3 und S1 B3.

Nun moechte ich, dass der Wert aus N1 in eine zufaellig ausgewaehlte Zelle zwischen N3 und N20 einmalig uebertragen wird. Alle Zellen zwischen N3 und N20 sind leer. Der Wert darf nur in eine dieser Zellen uebertragen werden, die Auswahl an die zu uebertragende Zelle soll beim Oeffnen zufaellig geschehen.

Das ganze auch fuer O1 (ab O3 bis O20), P1 (P3 bis P20) usw. bis S1...

Ich hoffe, dass es verstaendlich ausgedrueckt ist und bedanke mich im Vorraus fuer eure Vorschlaege

MfG
René

  

Betrifft: Das kann man auch per Funktionen lösen von: NoNet
Geschrieben am: 08.10.2007 16:12:28

Hallo Rene,

das kannst Du auch ohne VBA per Funktionen lösen :

MNOP
1Inhalt :xyz
2Zeile :10195
3
4
5z
6
7
8
9
10x
11
12
13
14
15
16
17
18
19y
20

N2   =RANDBETWEEN(3;20)
N3   =WENN(ZEILE()=N$2;N$1;"")
N4   =WENN(ZEILE()=N$2;N$1;"")
N5   =WENN(ZEILE()=N$2;N$1;"")
N6   =WENN(ZEILE()=N$2;N$1;"")
N7   =WENN(ZEILE()=N$2;N$1;"")
N8   =WENN(ZEILE()=N$2;N$1;"")
N9   =WENN(ZEILE()=N$2;N$1;"")
N10   =WENN(ZEILE()=N$2;N$1;"")
N11   =WENN(ZEILE()=N$2;N$1;"")
N12   =WENN(ZEILE()=N$2;N$1;"")
N13   =WENN(ZEILE()=N$2;N$1;"")
N14   =WENN(ZEILE()=N$2;N$1;"")
N15   =WENN(ZEILE()=N$2;N$1;"")
N16   =WENN(ZEILE()=N$2;N$1;"")
N17   =WENN(ZEILE()=N$2;N$1;"")
N18   =WENN(ZEILE()=N$2;N$1;"")
N19   =WENN(ZEILE()=N$2;N$1;"")
N20   =WENN(ZEILE()=N$2;N$1;"")
O2   =RANDBETWEEN(3;20)
O3   =WENN(ZEILE()=O$2;O$1;"")
O4   =WENN(ZEILE()=O$2;O$1;"")
O5   =WENN(ZEILE()=O$2;O$1;"")
O6   =WENN(ZEILE()=O$2;O$1;"")
O7   =WENN(ZEILE()=O$2;O$1;"")
O8   =WENN(ZEILE()=O$2;O$1;"")
O9   =WENN(ZEILE()=O$2;O$1;"")
O10   =WENN(ZEILE()=O$2;O$1;"")
O11   =WENN(ZEILE()=O$2;O$1;"")
O12   =WENN(ZEILE()=O$2;O$1;"")
O13   =WENN(ZEILE()=O$2;O$1;"")
O14   =WENN(ZEILE()=O$2;O$1;"")
O15   =WENN(ZEILE()=O$2;O$1;"")
O16   =WENN(ZEILE()=O$2;O$1;"")
O17   =WENN(ZEILE()=O$2;O$1;"")
O18   =WENN(ZEILE()=O$2;O$1;"")
O19   =WENN(ZEILE()=O$2;O$1;"")
O20   =WENN(ZEILE()=O$2;O$1;"")
P2   =RANDBETWEEN(3;20)
P3   =WENN(ZEILE()=P$2;P$1;"")
P4   =WENN(ZEILE()=P$2;P$1;"")
P5   =WENN(ZEILE()=P$2;P$1;"")
P6   =WENN(ZEILE()=P$2;P$1;"")
P7   =WENN(ZEILE()=P$2;P$1;"")
P8   =WENN(ZEILE()=P$2;P$1;"")
P9   =WENN(ZEILE()=P$2;P$1;"")
P10   =WENN(ZEILE()=P$2;P$1;"")
P11   =WENN(ZEILE()=P$2;P$1;"")
P12   =WENN(ZEILE()=P$2;P$1;"")
P13   =WENN(ZEILE()=P$2;P$1;"")
P14   =WENN(ZEILE()=P$2;P$1;"")
P15   =WENN(ZEILE()=P$2;P$1;"")
P16   =WENN(ZEILE()=P$2;P$1;"")
P17   =WENN(ZEILE()=P$2;P$1;"")
P18   =WENN(ZEILE()=P$2;P$1;"")
P19   =WENN(ZEILE()=P$2;P$1;"")
P20   =WENN(ZEILE()=P$2;P$1;"")

Tabelle eingefügt mit Syntaxhighlighter 4.12


HINWEIS : In der deutschen EXCEL-Version muss es anstelle "RANDBETWEEN(...)" ZUFALLSBEREICH(...) heißen !
Diese Funktion steht erst dann zur Verfügung, wenn das AddIn "Analysis Toolpak" (bzw. "Analyse-Funktionen") aktiviert wurde !

Gruß, NoNet


  

Betrifft: AW: Das kann man auch per Funktionen lösen von: René
Geschrieben am: 08.10.2007 16:32:46

Klasse!! Das Ding is ja super geloest, funzt!!! Herzlichen Dank

Mfg
René


 

Beiträge aus den Excel-Beispielen zum Thema "Zellwert per Zufall uebertragen!"