Microsoft Excel

Herbers Excel/VBA-Archiv

Formel zum Filtern gesucht

Betrifft: Formel zum Filtern gesucht von: Ralf
Geschrieben am: 15.04.2008 15:55:15

Hallo Forum,

ich möchte in einer Tabelle nach 2 verschiedenen Kriterien zählen.
In Spalte I stehen Geldbeträge der einen Abteilung in Spalte J und K die Beträge der anderen beiden
Abteilungen.
Jetzt filtere ich die Anzahl (nicht die Summe) der Beträge über die Formel
ZÄHLENWENN(I2:I231;"größer 0") Ergebnis: 74
heraus. Dies ist soweit i. O.
Nun möchte ich von diesem Ergebnis die Anzahl nach festgelegten Kriterien aus Spalte B reduzieren.
Ein Aneinanderreihen von Kriterien mit Zählenwenn geht offenbar nicht.
Ich stelle mir das sinngemäß so vor.
ZÄHLENWENN(I2:I231;"größer 0")-ZÄHLENWENN(b2:b231;"Sonderwerkzeug") Ergebnis: 74-5=69
Zählen der Anzahl der Beträge in Spalte I größer 0 abzüglich der Anzahl der "Sonderwerkzeuge" die diese
Abteilung betreffen.

Mit dieser Formel in Zeile 234
ZÄHLENWENN(I2:I231;"größer 0")-ZÄHLENWENN(B2:B231;"Sonderwerkzeug")
werden als Ergebnis in der Zelle I234 51 ausgegeben, was natürlich falsch ist (Ergebnis: 74-23). Für sich
betrachtet geben die beiden Operationen das richtige Ergebnis aus. Aber nicht in Bezug auf die Abteilung.

Die Sonderwerkzeuge verteilen sich auf 3 Abteilungen. Ich kann die beiden Operationen nicht in Bezug
zueinander bringen. Es sind insgesamt 23 Sonderwerkzeuge in der Liste. Diese verteilen sich auf Abt. 1 mit

5 Stück, Abt. 2 mit 11 Stück und Abt. 3 mit 7 Stück.

Kann mir da bitte jemand mit einer passenden Formel/Funktion helfen? Ich habe zum besseren Verständnis eine Beispiel Arbeitsmappe angehängt.
https://www.herber.de/bbs/user/51575.xls

Danke schon mal im voraus.

Gruß

Ralf

  

Betrifft: AW: Formel zum Filtern gesucht von: David
Geschrieben am: 15.04.2008 16:10:54

Die Formeln

=SUMMENPRODUKT((I2:I231>0)*($B$2:$B$231="Sonderwerkzeug")*1)
=SUMMENPRODUKT((J2:J231>0)*($B$2:$B$231="Sonderwerkzeug")*1)
=SUMMENPRODUKT((K2:K231>0)*($B$2:$B$231="Sonderwerkzeug")*1)



sollten dein Problem lösen.

Ich bin auch noch rel. neu bei den Summenprodukt-Formeln, aber wenn man sich damit beschäftigt, lassen sich eine Menge Dinge realisieren...

Gruß

David


  

Betrifft: AW: Formel zum Filtern gesucht von: Ralf
Geschrieben am: 15.04.2008 21:07:21

Servus David,

passt. Vielen Dank.
Funktioniert bestens. Die Funktion kannte ich, wußte diese aber nicht anzuwenden. Jetzt weiß ich es.

Viele Grüße

Ralf


  

Betrifft: AW: Formel zum Filtern gesucht von: David
Geschrieben am: 16.04.2008 08:12:23

Für mich war die Erkenntnis wichtig, dass man mit der Summenprodukt-Formel einfach Wahrheitswerte multiplizieren kann, wobei Falsch=0 und Wahr=1 ist. Als ich das erst mal verstanden hatte, war der Rest ganz einfach.

Gruß

David


 

Beiträge aus den Excel-Beispielen zum Thema "Formel zum Filtern gesucht"