Microsoft Excel

Herbers Excel/VBA-Archiv

Werte in Matrix-Tabelle unter Bedingung summieren

Betrifft: Werte in Matrix-Tabelle unter Bedingung summieren von: Michael
Geschrieben am: 16.04.2008 22:25:41

Hallo,
ich habe folgendes Problem:

ich habe eine Matrix mit Werten {4473; 4474} nun will ich aus einer weiteren Tabelle alle Einträge finden mit diesen Nummern und sofern eine weitere Bedingung zutrifft z. B Key = "abc", dann soll die dritte Spalte über alle Treffer aufsummiert werden. Ich habe glaube ich da Schwierigkeiten, da die Matrix und die Zeilen meiner Tabelle unterschiedlich groß sind bzw. sein können:

Tabelle
0123 abc 1
4473 abc 3
4474 zyl 4
4567 abc 5

Ergebnis wäre dann 3, da in Spalte 1 die 4473 und in Spalte 2 "abc" steht.
Weiß da jemand eine Lösung?

Vielen Dank für die Hilfe!

  

Betrifft: AW: Werte in Matrix-Tabelle unter Bedingung summieren von: Christian
Geschrieben am: 16.04.2008 22:56:57

Hallo Michael,

als Ansatz:

Tabelle2

 ABCDE
1123abc1 3
24473abc3  
34474zyl4  
44567abc5  

Formeln der Tabelle
ZelleFormel
E1=SUMMENPRODUKT(((A1:A100=4473)+(A1:A100=4474))*(B1:B100="abc"); C1:C100)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

MfG Christian


 

Beiträge aus den Excel-Beispielen zum Thema "Werte in Matrix-Tabelle unter Bedingung summieren"