Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrfach vorkommende Daten markieren

Betrifft: Mehrfach vorkommende Daten markieren von: Bernd
Geschrieben am: 25.06.2008 14:34:06

Tag zusammen,

ich habe folgendes Problem:

Um zu vergleichen, ob mehrere Datensätze (ca. 8.000 Stück) identisch sind, habe ich über die Funktion VERKETTEN mehrere Daten (aus 6 Spalten) miteinander verknüpft und wollte über die Funktion ZÄHLENWENN mir die mehrfach vorkommenden anzeigen lassen (mit einem "X") , aber irgendwie funktioniert dies nicht richtig (ist ZÄHLENWENN evtl. nur für eine bestimmte Anzahl von Zeichen möglich?).

Gibt es noch eine andere Möglichkeit?!

Gruß Bernd

  

Betrifft: wie sieht denn Deine Hilfsspaltenformel aus ... von: neopa
Geschrieben am: 25.06.2008 14:44:13

Hallo Bernd,

... angenommen Du überprüfst Spalte A, könnte die Formel z.B. so aussehen

=WENN(ZÄHLENWENN(A:A;A1)>1;"x";"")  

und sollte auch für 8000 Datensätze funktionieren (jedoch nicht getestet)

Gruß Werner
.. , - ...


  

Betrifft: AW: wie sieht denn Deine Hilfsspaltenformel aus ... von: Bernd
Geschrieben am: 25.06.2008 14:57:12

Hallo Werner,

herzlichen Dank für deine Antwort. Aber genau bei dieser einfachen Formel bringt er mir nahezu alle, auch die Datensätze, die nicht identisch sind!

Gruß Bernd


  

Betrifft: AW: Mehrfach vorkommende Daten markieren von: Uwe (:o)
Geschrieben am: 25.06.2008 14:50:46

Hi Bernd,
das wusste ich zwar auch noch nicht, aber ich habe es mal ausgetestet:
Es funktioniert nur bis max. 255 Zeichen.
Als Alternative fiele mir nur ein das Ganze auf 2 x 3 zu splitten und dann nochmal zu vergleichen.
Aber bestimmt hat jemand 'ne besser Idee.

Gruß
Uwe
(:o)


  

Betrifft: AW: Mehrfach vorkommende Daten markieren von: Bernd
Geschrieben am: 25.06.2008 14:59:38

Hallo Uwe,

danke für die Info. Vielleicht liegt es auch daran, dass zwei Spalten ein Datum sind und die anderen "normale" Zahlen?!

Gruß Bernd


  

Betrifft: also wenn es sich nur um Zahlen handelt ... von: neopa
Geschrieben am: 25.06.2008 15:27:45

Hallo Bernd,

... und Datumswerte sind ja auch Zahlen, könntest Du ja mal (ohne Hilfsspaltenverkettung) einfach mit SUMMENPRODUKT() prüfen (8000 Formeln dürften vielleicht gerade noch angehen)

z.B. so für Spalte A:F

=WENN(SUMMENPRODUKT((A$1:A$8000=A2)*(B$1:B$8000=B2)*(C$1:C$8000=C2)*(D$1:D$8000=D2)*(E$1:E$8000=E2) *(F$1:F$8000=F2))>1;"x";"") 

und Formel nach unten ziehen.


Gruß Werner
.. , - ...


  

Betrifft: AW: also wenn es sich nur um Zahlen handelt ... von: Bernd
Geschrieben am: 25.06.2008 16:28:49

Hallo Werner,

paßt! Super , danke!

Gruß Bernd


 

Beiträge aus den Excel-Beispielen zum Thema "Mehrfach vorkommende Daten markieren"