Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn mit abhängigen Bereichen

Betrifft: Summewenn mit abhängigen Bereichen von: Kriswater
Geschrieben am: 29.07.2008 08:52:53

Hallo zusammen!
Ich habe folgendes Problem:
Meine Tabelle enthält einen Bereich, der folgendermaßen aufgebaut ist:

Kostenstelle Kostenart1 Kostenart 2 etc...
1234 21€ 10€
1234 14€ 15€
1122 10€ 69€

In einem anderen Teil der Tabelle stehen die Kostenstellen erneut, aber transponiert:
1234 Kostenart1 Summe??
1234 Kostenart2 Summe??
etc..

Insgesamt stehen etliche tausend Kostenstellen untereinander. Ich benötige also eine Summewenn Funktion, die die Spalte, die aufsummiert werden soll in Abhängigkeit von der Kostenart im Ausgabebereich ermittelt.
Ich habe schon das Forum durchsucht und verschiedene Matrix Formeln probiert. Leider ohne Erfolg.
Könnt Ihr helfen??
Vielen Dank
LG
Kris

  

Betrifft: AW: Summewenn mit abhängigen Bereichen von: Andreas Emmert
Geschrieben am: 29.07.2008 09:37:33

Hallo Kris,

meinst du so etwas:
https://www.herber.de/bbs/user/54189.xls

Viele Grüße
Andreas


  

Betrifft: AW: Summewenn mit abhängigen Bereichen von: Rudi Maintaire
Geschrieben am: 29.07.2008 09:39:24

Hallo,





  A B C D E F G H I J K L
1 Kostenstelle Kostenart1 Kostenart2 Kostenart3 Kostenart4 Kostenart5 Kostenart6 Kostenart7   Kostenstelle Kostenart Summe
2 1234 21 € 10 €             1234 Kostenart1 35
3 1234 14 € 15 €             1234 Kostenart2 25
4 1122 10 € 69 €             1122 Kostenart1 15
5 1122 5 13                  
 Zur Formelanzeige mit der Maus auf die gelben Zellen gehen


Formel in L2: =SUMMEWENN($A$1:$A$1000;J2;BEREICH.VERSCHIEBEN($A$1:$A$1000;;VERGLEICH(K2;$B$1:$H$1;)))
Gruß
Rudi


  

Betrifft: Schau mal in den ersten Thread da hat {Boris} ... von: backowe
Geschrieben am: 29.07.2008 09:39:34

Hi,

... Dir schon eine Lösung gepostet! ;)

Gruss Jürgen


  

Betrifft: AW: Summewenn mit abhängigen Bereichen von: Kriswater
Geschrieben am: 29.07.2008 09:50:21

Sorry, war versehentlich doppelt drin.
Ist erledigt


 

Beiträge aus den Excel-Beispielen zum Thema "Summewenn mit abhängigen Bereichen"