Microsoft Excel

Herbers Excel/VBA-Archiv

ZÄHLENWENN mit mehr als 15-Stelligen Zahlen

Betrifft: ZÄHLENWENN mit mehr als 15-Stelligen Zahlen von: kritzi
Geschrieben am: 29.07.2008 17:16:50

Hallo,

ich möchte für die Inventur die Liste mit den gezählten Seriennummern mit der Bestandsliste vergleichen.
Zu diesem Zweck benutze ich folgende Formel:

=ZÄHLENWENN(Bestandsliste!$I$2:$I$140;$A2)

Die Datenfelder an sich sind hier nicht von relevanz, denn die Formel an sich Funktioniert.
Allerdings vergleicht die Formel bei Zahlen über 15 Stellen nicht richtig:

Beispiel:

A1 = 1234567890123450
A2 = 1234567890123451
ZÄHLENWENN(A1;A2) = 1 <- FALSCH!

Währen in der Seriennummer Buchstaben oder Zeichen enthalten, würde es zu disem Verhalten nicht kommen. Da ich die Seriennummern selber aber nicht ändern kann, bräuchte ich irgend ein Workaround, um meine Inventurliste überprüfen zu können.

Version: Microsoft Excel 2002 (10.6841.6839) SP3

  

Betrifft: =SUMMENPRODUKT((A1=A2)*1) von: WF
Geschrieben am: 29.07.2008 17:57:06

.


  

Betrifft: AW: =SUMMENPRODUKT((A1=A2)*1) von: Erich G.
Geschrieben am: 29.07.2008 18:46:47

Hallo Walter,
wäre das nicht einen neuen Eintrag wert?

analog http://www.excelformeln.de/formeln.html?welcher=289

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: nööh, ist zu banal von: WF
Geschrieben am: 29.07.2008 21:37:37

.


  

Betrifft: AW: =SUMMENPRODUKT((A1=A2)*1) von: kritzi
Geschrieben am: 30.07.2008 10:32:47

vielen dank, das funktioniert genau so wie ich es haben möchte.


  

Betrifft: AW: ZÄHLENWENN mit mehr als 15-Stelligen Zahlen von: Daniel
Geschrieben am: 29.07.2008 19:33:44

Hi

Zahlen über 15 Stellen sollte man sowieson nicht verwenden, weil Excel damit nicht rechnen kann, sondern nach der 15 Stelle einfach rundet, dh. aus 1234567890123451 wird 1234567890123450, somit sind beide Werte für ZählenWenn gleich.
auch das Summenprodukt von WF versagt in diesem Fall

Wenn du nicht irgendwann ein grossen Problem bekommen willst mit fälschlicherweise gleichen Seriennummern, dann musst du deine Serien-Nummern auf jeden Fall als Text einstellen.
dazu würde eine der 3 Methoden ausreichen:
- die Zellen vor eingabe als TEXT zu formatieren
- das Hochkomma ' bei der eingabe voran zu stellen
- ein Leerzeichen am Anfang oder Ende mit einzugeben

das Problem an der Sache ist, daß ZählenWenn diese 3 Methoden ignoriert und intern trotzdem versucht, den Text in eine Zahl umzuwandeln (vermutlich, weil damit schneller gerechnet werden kann). Damit schlägt aber wieder die 15-Stellen-beschränkung zu.
(in diesem Fall arbeitet das SummenProdukt von WF richtig)

erst wenn du zu der Seriennummer ein Zeichen hinzufügt, daß aus der Nummer eindeutig einen Text macht (z.B. "_" oder "N"), dann interpretiert auch ZählenWenn den Wert als Text und vergleicht richtig.

Gruß, Daniel


  

Betrifft: > 15 Stellen ist LOGO Text von: WF
Geschrieben am: 29.07.2008 20:52:20

.


  

Betrifft: irgendwie nicht für ZählenWenn von: Daniel
Geschrieben am: 29.07.2008 21:53:12




  

Betrifft: AW: > 15 Stellen ist LOGO Text von: Uduuh
Geschrieben am: 29.07.2008 23:24:18

Hallo Walter,
nicht unbedingt. Der Textkonvertierungsassi macht aus 1234567890123456789 standardmäßig 1234567890123450000. Folglich werden die Art-Nr. vernichtet. Das muss man schon explizit als Text importieren.

Gruß aus’m Pott
Udo



  

Betrifft: auch logo von: WF
Geschrieben am: 29.07.2008 23:29:36

ich meinte, wenn man mehr als 15 Ziffern ungleich 0 sieht, ist das eben Text.

WF


  

Betrifft: AW: > 15 Stellen ist LOGO Text von: kritzi
Geschrieben am: 30.07.2008 10:37:55

Hallo,

ja, ich habe die Seriennummern als Text eingegeben, sonst hätte ich ja auch keine Nummern mit mehr als 15 Stellen eingeben können.
Allerdings bin ich bei dem Format der Seriennummer etwas gebunden, da die diese über einen Barcodescanner eingebe.

Aber mit der SUMMENPRODUKT Formel konnte ich das Problem ja ganz gut umgehen.


 

Beiträge aus den Excel-Beispielen zum Thema "ZÄHLENWENN mit mehr als 15-Stelligen Zahlen"