Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summen Formel

Summen Formel
02.08.2008 13:28:00
Andreas
Hallo Excel Profis,
Ich suche eine Datumsabhängige Formel.
In der Zelle B3 soll z.B. folgendes berechnet werden:
Wenn in Spalte O ein Datum im Bereich Juni 2008 liegt soll er mir die Summe aus den jeweiligen
Zellen der Spalte L rechnen.
kann mir jemand bei meinem Problem weiterhelfen?
Im Vorraus vielen Dank
Andreas

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summen Formel
02.08.2008 13:32:00
Hajo_Zi
Hallo Andreas,
Summe für ein Monat
leer wird als Januar interpretiert / Excel bzw. Billy spinnen
um dieses auszuschließen:
=SUMMENPRODUKT((A1:A100"")*(MONAT(A1:A100)=1)*B1:B100)
hier werden die Werte aus B addiert wenn in A der Monat Januar steht (egal, welches Jahr)
Mit Jahreseingrenzung auf 2003 so:
=SUMMENPRODUKT((A1:A100"")*(MONAT(A1:A100)=1)*(JAHR( A1:A100)=2003)*B1:B100)

AW: Summen Formel
02.08.2008 13:49:10
Andreas
Hallo Hajo,
Erst einmal danke für deine prompte Antwort,
jedoch verstehe ich deine Formel noch nicht wirklich!
Mein Problem ist, wie ich die Formel umstellen muss, damit die Formel mir z.B. alle Zellen aus der Spalte L die in Spalte O (Datumsbereich Juni) liegen die Werte Summiert.
Gruß Andreas

Anzeige
AW: Summen Formel
02.08.2008 13:56:32
Erich
Hi Andreas,
hier noch mal alle vorgeschlagenen Formeln:
(in Zeile 15,16 stehen nur zwei Datumse in Zahl- und Datumsformat.)
 BC
815 
915 
1015 
1115 
1215 
1315 
14  
153962930.06.2008
163960001.06.2008

Formeln der Tabelle
ZelleFormel
B8=SUMMENPRODUKT((O1:O100<>"")*(MONAT(O1:O100)=6)*(JAHR( O1:O100)=2008)*L1:L100)
B9=SUMMENPRODUKT((MONAT(O1:O9999)&JAHR(O1:O9999)="62008")*L1:L9999)
B10=SUMMENPRODUKT((TEXT(O1:O9999;"MMJJJJ")="062008")*L1:L9999)
B11=SUMMENPRODUKT((TEXT(O1:O9999;"MJJJJ")="62008")*L1:L9999)
B12{=SUMME(WENN(TEXT(O1:O9999;"MJJJJ")="62008";L1:L9999))}
B13=SUMMEWENN(O:O;"<=39629";L:L)-SUMMEWENN(O:O;"<39600";L:L)
C15=B15
C16=B16
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort

Anzeige
Danke!
02.08.2008 14:16:00
Andreas
Danke funktioniert!

AW: Summenformel
02.08.2008 13:39:00
Erich
Hallo Andreas,
oder so:
=SUMMENPRODUKT((MONAT(O1:O9999)&JAHR(O1:O9999)="82008")*L1:L9999)
Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort

AW: Summenformel
02.08.2008 13:42:00
Erich
Hallo Andreas,
und noch zwei Varianten dazu:
 B
915
1015
1115

Formeln der Tabelle
ZelleFormel
B9=SUMMENPRODUKT((MONAT(O1:O9999)&JAHR(O1:O9999)="82008")*L1:L9999)
B10=SUMMENPRODUKT((TEXT(O1:O9999;"MMJJJJ")="082008")*L1:L9999)
B11=SUMMENPRODUKT((TEXT(O1:O9999;"MJJJJ")="82008")*L1:L9999)

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort

Anzeige
Danke!
02.08.2008 14:16:00
Andreas
Danke funktioniert!

AW: Summen Formel
02.08.2008 13:43:16
Daniel
Hi
zum Beispiel so:

=SUMMEWENN(O:O;"


dabei sind 39629 und 39600 die Zahlenwerte, die den Datümern 30.6.2008 und 1.6.2008 entsprechen.
Gruß, Daniel

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige