Microsoft Excel

Herbers Excel/VBA-Archiv

Rang-Funktion für Strings?

Betrifft: Rang-Funktion für Strings? von: Born
Geschrieben am: 05.08.2008 09:56:57

Hallo Forum,
gibt es eine Funktion, mit der ich aus einem Zellbereich, der mit Strings gefüllt ist, den "kleinsten" String ermitteln kann (wobei klein jeweils sich auf die Sortierung von A...Z bezieht), ohne dass ich diese Liste alphabetisch sortiere? Für Zahlen gibt es hier die Rang-Funktion, aber für Stings habe ich nichts vergleichbares gefunden.

Vielen Dank im Voraus,
M. Born

  

Betrifft: AW: Rang-Funktion für Strings? von: ransi
Geschrieben am: 05.08.2008 10:00:27

HAllo

Mal als Ansatz:
Tabelle1

 BC
1 Name
210GKINP
323G0L3
48F04LJ
56C6DF6
615ON82G
759JB8D
8378HW7
913LE00V
1016UR3KV
11498S18
1211GX25L
1314NDVAZ
1412GZ1AC
1518XQ0T3
1619ZJRIA
179GIL5M
1812UD05
197D5N9R
2017VWLRP
21  

Formeln der Tabelle
ZelleFormel
B2=ZÄHLENWENN($C$2:$C$20;"<=" &C2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

ransi


  

Betrifft: AW: Rang-Funktion für Strings? von: Born
Geschrieben am: 05.08.2008 10:12:40

Hallo Ransi,
das war genau das, was ich gesucht habe.

Vielen Dank,
M. Born


  

Betrifft: Nachtrag von: mpb
Geschrieben am: 05.08.2008 12:37:28

Hallo,

für den Fall, das nur das Minimum benötigt wird:

aus http://www.excelformeln.de/formeln.html?welcher=236


=INDEX($A$1:$A$10;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$1:A$10;"<"&A$1:A$10);ZEILEN(A$1:A1)); ZÄHLENWENN(A$1:A$10;"<"&A$1:A$10);0))

Gruß
Martin


  

Betrifft: AW: Nachtrag von: Born
Geschrieben am: 05.08.2008 13:45:48

Hallo Martin,
vielen Dank für Deine Hilfe.

M. Born


  

Betrifft: Nachfrage von: mpb
Geschrieben am: 05.08.2008 10:11:50

Hallo,

welche Zeichen kommen in den Strings vor (einschließlich Groß-/Kleinschreibung)? Wie lang sind die Strings(maximal)?

Gruß
Martin


  

Betrifft: AW: Nachfrage von: Born
Geschrieben am: 05.08.2008 12:33:18

Hallo Martin,
das Problem konnte zwischenzeitlich gelöst werden. Vielen Dank, dass Du mir auch helfen wolltest.

Viele Grüße,
M. Born


 

Beiträge aus den Excel-Beispielen zum Thema "Rang-Funktion für Strings?"