Microsoft Excel

Herbers Excel/VBA-Archiv

Spalten Vergleichen

Betrifft: Spalten Vergleichen von: oliver
Geschrieben am: 05.08.2008 11:35:09

Hallo,
da ich nun schon einige Tage erfolglos ein Problem beseitigen wollte, wende ich mich nun an euch, in der Hoffnung, dass jemand eine Lösung für mich hat:

In meiner Datei sind in Spalte A - T je zwischen 500 und 600 Zahlen.
In Spalte A befinden sich alle "möglichen" Zahlen, die in den restlichen Spalten vorkommen können.
In B - T kommen diese mal vor oder auch nicht.
Die Spalten sind unterschiedlich lang und unsortiert.

Ich möchte nun entweder:
1.) eine neue Spalte in der angegeben wird: "wie oft kommt die zahl in A1 in den Spalten B - T vor?" dies natürlich für alle nachfolgenden Zahlen in Spalte A.
oder:
2.) Die Zelle in Spalte A soll grün markiert werden, wenn die enthaltene Zahl in den Spalten B - T mindestens 19 mal irgendwo auftaucht.

Hintergrund ist eine Registrierung der Teilnahme einer Großveranstaltung per Barcodescanner. Bei jedem Veranstaltungstermin werden die Teilnehmer per Ausweis erfasst. Am Ende soll herausgefunden werden, wie viele Veranstaltungen der Einzelne besucht hat um dann ggf. einen Leistungsnachweis rauszugeben.

Ich danke Euch,
Oliver

  

Betrifft: AW: Spalten Vergleichen von: heikoS
Geschrieben am: 05.08.2008 11:43:01

Hallo Oliver,

das sollte z.B. so gehen:

Tabelle1

 ABCDEF
1KriterienAnzahlReihe1Reihe2Reihe3Reihe4
224312 
357625 
46345  
5424661
6125392
7   203
8   3 5
9   5 5
10     5
11     8

Formeln der Tabelle
ZelleFormel
B2=ZÄHLENWENN($C$2:$F$11;A2)

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A21. / Zellwert ist grösser oder gleich 5Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Klappt´s?


Gruß Heiko


  

Betrifft: AW: Spalten Vergleichen von: oliver
Geschrieben am: 05.08.2008 12:01:38

Hallo Heiko und vielen Dank, das ist schonmal super ... vor allem einfacher als ich dachte.

Ich habe nur noch das Problem, das ich die Formel in Zelle B2 nicht einfach runterziehen kann. Er fängt dann in der nächsten Zelle ab C3 an u.s.w.

Muss ich die Formatierung komplett per Hand editieren, oder gibt es dafür auch noch einen bequemeren Weg?


  

Betrifft: AW: Spalten Vergleichen von: David
Geschrieben am: 05.08.2008 12:11:37

Hallo Oliver,

achte auf die $-Zeichen in der Formel, ohne diese werden die Bezüge beim runterkopieren angepaßt, mit bleiben sie wie eingegeben.

Gruß

David


  

Betrifft: AW: Spalten Vergleichen von: oliver
Geschrieben am: 05.08.2008 12:18:51

Wie Geil ist das denn?

Genauso habe ich mir das vorgestellt! Habe die Dollarzeichen bei Heikos Beitrag völlig übersehen ... Gute Basic die ich noch nicht kannte.

Danke euch beiden, tolles und vor allem schnelles Forum
:-)


  

Betrifft: Erläuterung relative und absolute Bezüge von: heikoS
Geschrieben am: 05.08.2008 12:59:09

Hallo Oliver,

auch wenn das Problem bereits gelöst ist, der beigefügte Link könnte für Dich interessant sein:

http://www.online-excel.de/excel/singsel.php?f=56


Gruß Heiko


 

Beiträge aus den Excel-Beispielen zum Thema "Spalten Vergleichen"