Microsoft Excel

Excel und VBA: Formeln, Programmierung, Lösungen

Die Summenfunktion von Excel ist sehr vielgestaltig. Es gibt verschiedene Wege, um Summen zu errechnen. Nehmen wir zunächst den logischen Weg. Hier eine Beispieltabelle aus Excel, wo eine Summe integriert werden soll.

Abbildung - Summen einfügen
Summen einfügen

Der naheliegende Weg ist das Einfügen einer Funktion, die sämtliche Einzelwerte addiert. Da Sie bereits wissen, daß Formeln immer mit einem =-Zeichen beginnen und das Additionszeichen feststeht, lautet hier die Formel also:

=b3+b4+b5+b6

Excel wird nun in der markierten Zelle dazu veranlaßt, die Zellen, auf die die Formel bezug nimmt, zu addieren. Excel zeigt nun nicht die eingegebene Formel an, sondern das Ergebnis dieser Addition.

Abbildung - Summenberechnung über die Addition von Einzelzellen
Summe

Summen über einen größeren Bereich

Diese Art der Summenberechnung erscheint auf den ersten Blick logisch und am einfachsten. Jedoch muß man auch berücksichtigen, daß es durchaus längere Zahlenkolonnen geben kann, aus denen eine Summe gebildet werden muß. Hier ist z.B. die Errechnung eines Jahresumsatzes über 12 Monate denkbar. Es macht hier aus Gründen der Arbeitszeit wenig Sinn, alle Zellbezüge einzeln aufzulisten. Vielmehr sollte man hier einen Bereich angeben aus dem die Summe errechnet werden soll. Diese Bereiche kennzeichnet man durch einen Doppelpunkt (:).

Um bei dem obigen Beispiel zu bleiben, müßte der Bereich für die Summenbildung nun so angegeben werden:

b3:b6

Da Excel jetzt jedoch noch nicht weiß, daß aus diesem Bereich eine Summe gebildet werden muß, ist es notwendig, ihm die Rechenart mitzuteilen. Außerdem muß, wie bei jeder Formel, noch ein Gleichheitszeichen vor Beginn der Formel stehen. Die vollständige Formel lautet dann:

=summe(b3:b6)

Diese Formel wird zusammengeschrieben. Der Zellbereich, der in diesem Fall addiert werden soll, muß durch Klammern von der Rechenfunktion getrennt werden.

Arbeitsvereinfachung mit der Maus

Für die Standard-Summenfunktion bietet Excel ein Symbol Summensymbol auf der Arbeitsoberfläche an, welches Sie bei der Erstellung von Summenformeln unterstützen soll.

Hier einige Tips zur Vorgehensweise:
  • Markieren Sie zunächst die Zelle, in die die Summe eingefügt werden soll.
  • Klicken Sie jetzt auf das Summenzeichen.
  • Mit gedrückter linker Maustaste ziehen Sie jetzt den Bereich auf der Tabelle ab, aus dem die Summe gebildet werden soll.
  • Häufig schlägt Excel Ihnen bereits einen richtige Bereich vor.
  • Bestätigen Sie die Eingabe mit der Return-Taste.
Abbildung - Summen mit Hilfe des Summen-Zeichens
Summen mit Hilfe des Summen-Zeichens Was passiert jedoch, wenn Sie die Summen aus einem nicht zusammenhängenden Bereich errechnen möchten?. Hierzu benötigen Sie die Steuerungstaste.

Bleiben wir bei dem Beispiel von oben. Es soll nicht die Gesamtsumme des Jahres errechnet werden, sondern nur die Summe des 2. und 4. Quartals. Dies ist ein nicht zusammenhängender Bereich. Mit der Maus kann man diesen Bereich also nicht markieren. Gehen Sie zum Errechnen dieser Summe wie folgt vor:

  • Markieren Sie die Zelle, in der die Summe eingefügt werden soll.
  • Klicken Sie auf das Summen-Zeichen.
  • Klicken Sie nun auf die erste Zelle, die für die Addition herangezogen werden soll.
  • Drücken Sie nun die Steuerungstaste (STRG) halten Sie diese gedrückt und klicken Sie mit der Maus auf die zweite Zelle, die berücksichtigt werden soll.
  • Wenn Sie auf diese Weise alle Zellen für die Summenbildung markiert haben, lassen Sie die Steuerungstaste wieder los und drücken Sie die Return-Taste.
Abbildung - Summen aus nicht zusammenhängenden Bereichen
In der Formeldarstellung steht nun

=SUMME(B6;B4)

Das Semikolon zwischen den Zellangaben zeigt eine Trennung der beiden Zellen an. Dieses Semikolon wird gleich noch eine Rolle spielen.

Summenbildung aus zwei verschiedenen Bereichen

Erweitern wir nun die Tabelle um das Jahr 2005. Auch hier gab es quartalsmäßig vier Umsatzzahlen.

Abbildung - Quartalsmäßige Umsätze über zwei Jahre


Es soll nun die Summe errechnet werden aus dem zweiten Halbjahr 2004 und dem ersten Halbjahr 2005.

Gehen Sie für die Berechnung der Summen folgendermaßen vor:

  • Markieren Sie die Zelle, in der die Summe später eingetragen werden soll.
  • Klicken Sie nun auf das Summen-Zeichen.
  • Markieren Sie den ersten Bereich, der für die Summenbildung in Frage kommt. In unserem Fall b5:b6.
  • Drücken Sie nun die Steuerungstaste, halten Sie diese gedrückt.
  • Markieren Sie nun den zweiten Bereich, der in die Summen einfließen soll. In diesem Fall c3:c4.
  • Bestätigen Sie die Formel mit der Return-Taste.
Abbildung - Summenbildung über zwei Bereiche
Summenbildung über zwei Bereiche

Die eingegebene Formel lautet nun:

=SUMME(B5:B6;C3:c4)

Mit dieser Schreibweise werden zwei nicht zusammenhängende Bereich addiert. Die Angabe von verschiedenen Bereichen kann beliebig erweitert werden.

Mit diesem Grundgerüst für die Formeleingabe lassen sich auch viele andere Berechnungen durchführen. Lediglich die Berechnungsmethode verändert sich. Die Angabe der Bereiche unterliegt immer den oben beschriebenen Regeln.