Microsoft Excel

Herbers Excel/VBA-Archiv

Summe bilden


Betrifft: Summe bilden von: ilka maria
Geschrieben am: 18.09.2019 15:58:14

Guten Tag,

es soll die Summe gebildet werden, wenn in Spalte A und Spalte B jeweils an 3. Stelle ein i steht?
Für Tipps besten Dank im Voraus.
Gruß ilka maria

https://www.herber.de/bbs/user/132098.xlsx

  

Betrifft: AW: Summe bilden von: 1713701.html
Geschrieben am: 18.09.2019 16:07:59

Hallo, so z.B..:

=SUMMENPRODUKT((TEIL(A1:A4;3;1)="i")*(TEIL(B1:B4;3;1)="i");C1:C4)

  

Betrifft: AW: Summe bilden von: 1713703.html
Geschrieben am: 18.09.2019 16:09:17

Hola,

=SUMMENPRODUKT((TEIL(A1:A4;3;1)="i")*(TEIL(B1:B4;3;1)="i");C1:C4)
 

Gruß,
steve1da
  

Betrifft: AW: Danke schön von: 1713753.html
Geschrieben am: 18.09.2019 20:08:57

für Deine Lösung.
Ich freue mich über alle Hilfen, sehe ich doch daran wie unterschiedlich man die Aufgabe lösen kann.
Danke.
Gruß ilka maria

  

Betrifft: AW: Summe bilden von: 1713704.html
Geschrieben am: 18.09.2019 16:11:46

Hallo Ilka,
der Klassiker: Summieren mit mehreren Bedingungen = Funktion SUMMENPRODUKT!
=SUMMENPRODUKT((TEIL(A1:A4;3;1)="i")*(TEIL(B1:B4;3;1)="i")*(C1:C4))

Gruß!
Klaus

  

Betrifft: AW: Danke schön von: 1713752.html
Geschrieben am: 18.09.2019 20:06:31

für Deine Lösung.
Mit Summenprodukt hatte ich es probiert, aber aus irgendwelchen Gründen dann doch nicht gelöst.
Danke.
Gruß ilka maria

  

Betrifft: AW: Summe bilden mit SUMME() und INDEX() von: 1713705.html
Geschrieben am: 18.09.2019 16:16:25

Hallo ilka, man kann auch alternativ ff. Formel nutzen..:

=SUMME(INDEX(C1:C4*(TEIL(A1:A4;3;1)="i")*(TEIL(B1:B4;3;1)="i");))

  

Betrifft: AW: BestenDank von: 1713751.html
Geschrieben am: 18.09.2019 20:03:37

für Deine beiden Lösungen.
Besonders überrascht hat mich die Lösung mit der Index-Funktion.
Danke.
Gruß ilka maria

  

Betrifft: INDEX ist überflüssig ... von: 1713755.html
Geschrieben am: 18.09.2019 20:49:47

... und dient nur der {}-Vermeidung.

Als Arrayformel:
{=SUMME(C1:C4*(TEIL(A1:A4;3;1)="i")*(TEIL(B1:B4;3;1)="i"))}

WF

  

Betrifft: ganz einfach mit SummeWenns und Jokern von: 1713706.html
Geschrieben am: 18.09.2019 16:27:05

 =SUMMEWENNS(C1:C4;A1:A4;"??i*";B1:B4;"??i*")

? - Joker für genau ein Zeichen
* - Joker für beliebig viele Zeichen (auch keins)
Gruß Daniel
  

Betrifft: AW: Vielen Dank von: 1713750.html
Geschrieben am: 18.09.2019 20:00:47

für Deine Hilfe.
Es hat mich überrascht, welch unterschiedliche Lösungsansätze ich erhalten habe.
Danke.
Gruß
ilka maria

Beiträge aus dem Excel-Forum zum Thema "Summe bilden"