VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Summe bilden, wenn Kriterium Zeichenfolge

Gruppe

Funktion

Bereich

SUMMEWENN

Thema

Summe bilden, wenn Kriterium Zeichenfolge

Problem

Ich habe eine Tabelle mit den Spalten Artikel und Anzahl. Ist es möglich, die Summe der Anzahl jener Artikel zu berechnen, die ein bestimmtes Wort enthalten?

Lösung

Ja, mit der EXCEL-Funktion "SUMMEWENN()". Wenn in A1:A100 die Artikel stehen und in B1:B100 die Anzahl steht, lautet die Formel für die Summe der Artikel "Hosen": =SUMMEWENN(A1:A100;"Hosen";B1:B100). Wildcards sind erlaubt.




StandardModule: basMain

Function SumItalic(rng As Range) As Double
   Dim rngAct As Range
   Dim dAdd As Double
   For Each rngAct In rng.Cells
      If IsNumeric(rngAct) Then
         If rngAct.Font.Italic = True Then
            dAdd = dAdd + rngAct.Value
         End If
      End If
   Next rngAct
   SumItalic = dAdd
End Function

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und SUMMEWENN