VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Summe bilden, wenn Kriterium Zahl

Gruppe

Funktion

Bereich

SUMMEWENN

Thema

Summe bilden, wenn Kriterium Zahl

Problem

Ich habe eine Tabelle mit einer Auflistung von Zahlen. Wie summiere ich die Zahlen, die größer als die Zahl in Zelle A1 sind?

Lösung

Mit der EXCEL-Funktion "SUMMEWENN()". Wenn die Liste der Zahlen in B1:B100 steht, lautet die Formel für das Summieren aller Zahlen, die größer als der Wert in A1 sind: =SUMMEWENN(B1:B100;">"&A1)




StandardModule: basMain

Function SumItalic(rng As Range) As Double
   Dim rngAct As Range
   Dim dAdd As Double
   For Each rngAct In rng.Cells
      If IsNumeric(rngAct) Then
         If rngAct.Font.Italic = True Then
            dAdd = dAdd + rngAct.Value
         End If
      End If
   Next rngAct
   SumItalic = dAdd
End Function

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und SUMMEWENN