Microsoft Excel

Herbers Excel/VBA-Archiv

zählenwenn-funktion mit mehreren kriterien

Betrifft: zählenwenn-funktion mit mehreren kriterien von: Walther
Geschrieben am: 16.07.2008 14:50:56

hallo! bin grad am verzweifeln :)
ich habe eine tabelle mit 2 spalten. möchte die anzahl der zellen wissen, bei denen in spalte A kriterium x und in spalte B kriterium y stimmt.
also so, als ob ich 2 filter setze und dann die datensätze/zeilen zähle.
hab gelesen, dass es die zählenwenns-funktion gibt, aber die funktioniert bei mir nicht, zählenwenns geht wohl erst bei office2007...

wer hat eine idee?

  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: Rudi Maintaire
Geschrieben am: 16.07.2008 14:54:48

Hallo,
=summenprodukt((A1:A100="x")*(B1:B100="Y"))

Gruß
Rudi


  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: Mustafa
Geschrieben am: 16.07.2008 14:57:05

Hallo Walther,

Folgende Formel für dein Beispiel mit Spalte A und B :

=SUMMENPRODUKT((A1:A100="a")*(B1:B100="x"))

Rückmeldung obs Hilft wäre nett.
Viele Grüße aus Köln.


  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: Walther
Geschrieben am: 16.07.2008 15:06:48

summenprodukt geht nicht, weil in den spalten text steht :(


  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: Mustafa
Geschrieben am: 16.07.2008 15:09:42

Ich vergleiche ja auch den Text der in den spalten steht.

=SUMMENPRODUKT((A1:A100="a")*(B1:B100="x"))


Gruß aus Köln.


  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: Walther
Geschrieben am: 16.07.2008 15:52:33

es funktioniert nicht


  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: David
Geschrieben am: 16.07.2008 16:25:04

dann ladt deine Datei doch mal hoch, wahrscheinlich fehlt uns mal wieder eine wichtige Info.
Mit solchen Postings wirst du sicher nicht zum Ziel kommen.

Gruß

David


  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: Hans-Joachim Santen
Geschrieben am: 16.07.2008 22:22:52

Hallo Walther,

geht es vielleicht so? Oder meinst Du noch etwas anderes?

Gesamtanzahl der übereinstimmenden Kriterien in Spalte A und B
Formel in E1
=ZÄHLENWENN(A1:A10;"x")+ZÄHLENWENN(B1:B10;"y")

oder so

Formel in E1
Anzahl der übereinstimmenden Kriterien getrennt für Spalte A und Spalte B in einer Zelle
="Spalte A= "&ZÄHLENWENN(A1:A10;"x")&"Spalte B= "&ZÄHLENWENN(B1:B10;"y")

Gruß Hans


  

Betrifft: AW: zählenwenn-funktion mit mehreren kriterien von: Walther
Geschrieben am: 17.07.2008 10:09:17

hallo.

die formel
=ZÄHLENWENN(A1:A10;"x")+ZÄHLENWENN(B1:B10;"y")
addiert ja die anzahl der datensätze, bei denen kriterium 1 und kriterium 2 zutrifft.
also anzahl kriterium 1 plus anzahl kriterium 2

ich hätte aber gern die anzahl der datensätze, bei denen kriterium in spalte A und kriterium in spalte B gleichzeitig zutrifft.

so, als wenn ich in einer tabelle 2 filter in 2 spalten setze und dann die anzahl der datensätze zähle, die ich gefiltert habe.


 

Beiträge aus den Excel-Beispielen zum Thema "zählenwenn-funktion mit mehreren kriterien"