Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn Funktion gekoppelt mit Links Funktion | Herbers Excel-Forum


Betrifft: Wenn Funktion gekoppelt mit Links Funktion von: kathy
Geschrieben am: 10.01.2012 23:20:19

Hallo Leute,

ich habe zwei verschiedene Zahlenformate (entweder 7 oder 8 stellig), z.B.

- 5-690.1
- 5-790.1C

Wie müsste die Formel aussehen, wenn man sagen möchte,

wenn(zahl 7stellig; dann links 3 zahlenwerte und wenn 8stellig dann links 4 zahlenwerte)

Vielen Dank für Eure Hilfe.

Gruß
kathy

  

Betrifft: AW: Wenn Funktion gekoppelt mit Links Funktion von: Markus
Geschrieben am: 10.01.2012 23:28:11

Hallo Kathy,

So? =WENN(Länge(A1)=7;Links(A1;3);Links(A1;4))

lg
Markus


  

Betrifft: AW: Wenn Funktion gekoppelt mit Links Funktion von: kathy
Geschrieben am: 10.01.2012 23:31:29

Hallo Markus,

vielen Dank. Die Formel ist perfekt und es funktioniert!

LG
kathy


  

Betrifft: oder: =LINKS(A1;3+(LÄNGE(A1)>7)) von: Erich G.
Geschrieben am: 11.01.2012 00:11:25

Hi Kathy,
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


Beiträge aus den Excel-Beispielen zum Thema "Wenn Funktion gekoppelt mit Links Funktion"