Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis oder Wenn Formeln???

Betrifft: Sverweis oder Wenn Formeln??? von: Pia
Geschrieben am: 17.08.2008 12:29:07

https://www.herber.de/bbs/user/54661.xls

Hallo zusammen,

wie kann man aus einem Tabellenblatt eine Wert von bestimmte Monate bestimmte Mitarbeiter auf anderen Tabellenblatt übertragen?
Sorry, ich kann es schwer erklären. Hoffentlich versteht ihr was ich damit meinte, anhand der beigefügten Excel-Liste.
Ich benötige den Umsatz von Frau Bauer im Januar an den Verkauf von Rolladen. Diese Zahl soll automatisch an anderes Tabellenblatt übertragen werden. Das Ergebsnis soll/muss 57.570 Euro sein.

Andere Frage : Wie macht man eine Drop Down Zelle für B1 und B2? So dass wenn ich B1 Zelle anklicke, es werden alle Name der Mitarbeiter angezeigt? Und bei anklicken von B2, Januar bis Dezember angezeigt werden?

Viele herzlichen Dank für Eure Hilfe!!!

Gruß,
Pia

  

Betrifft: Arrayformel mit Index/Vergleich von: WF
Geschrieben am: 17.08.2008 13:02:15

Hi Pia,

Da fehlt aber noch die Angabe der Jahreszahl, denn Bauerischen Rolladenumsatz gibt es in mehreren Januaren.
Jahreszahl also in B4

{=INDEX(Umsatzprovision!E:E;VERGLEICH(B1&B2&B3&B4; Umsatzprovision!A1:A999&Umsatzprovision!C1:C999&Umsatzprovision!D1:D999&Umsatzprovision!B1:B999;0)) }

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF


  

Betrifft: Summenprodukt von: Backowe
Geschrieben am: 17.08.2008 13:08:06

Hallo Pia,

da der Januar dreimal vorkommt, solltest Du noch eine zusätzliche Bedingung einfügen.

 ABCDE
1NameBauer NameBauer
2MonatJanuar MonatJanuar
3ProduktRolladen Jahr:1992
4   ProduktRolladen
5     
6Umsatz71.882,00 € Umsatz57.570,00 €

Formeln der Tabelle
ZelleFormel
B6=SUMMENPRODUKT((Umsatzprovisionen!$A$2:$A$757=B1)*(Umsatzprovisionen!$C$2:$C$757=B2)*(Umsatzprovisionen!$D$2:$D$757=B3)*Umsatzprovisionen!$E$2:$E$757)
E6=SUMMENPRODUKT((Umsatzprovisionen!$A$2:$A$757=E1)*(Umsatzprovisionen!B2:B757=E3)*(Umsatzprovisionen!$C$2:$C$757=E2)*(Umsatzprovisionen!$D$2:$D$757=E4)*Umsatzprovisionen!$E$2:$E$757)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Jürgen


  

Betrifft: AW: Summenprodukt von: Backowe
Geschrieben am: 17.08.2008 14:56:50

Hallo Pia,

ich hattest Dein Zusatzanliegen aber gut versteckt! ;o)

https://www.herber.de/bbs/user/54668.xls

Gruß Jürgen


  

Betrifft: AW: Sverweis oder Wenn Formeln??? von: Pia
Geschrieben am: 17.08.2008 15:46:06

Vielen Dank WF und Backowe für die schnelle Antwort!!!

Die Formel ist klasse!

@Jürgen : wie hast du denn die Drop Down Zelle gemacht? Das ist genau was ich wollte, bin neugierig wie man die Drop Down Zelle erstellen kann. Würdest du mir verraten? :)

Vielen Dank!
Pia


  

Betrifft: Daten, Gültigkeit, ... von: Backowe
Geschrieben am: 17.08.2008 16:32:37

Hallo Pia,

... dann unter "Zulassen" Liste auswählen und den Bereich angeben. Sollte der Bereich auf einem anderen Tabellenblatt liegen, mußt Du für den Bereich einen Namen vergeben, sonst funktioniert es nicht!

Gruß Jürgen


 

Beiträge aus den Excel-Beispielen zum Thema "Sverweis oder Wenn Formeln???"