Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN mit NICHT-Bedingung | Herbers Excel-Forum


Betrifft: SUMMEWENN mit NICHT-Bedingung von: Wolf
Geschrieben am: 21.01.2010 10:36:35

hallo, ich möchte die Werte einer Spalte addieren, wenn der Text in der Spalte zuvor nicht einem Vergleichswert entspricht (Suchkriterium). Ich habe das mit =SUMMEWENN(E15:E38;NICHT(TEXT(A41;""));D15:D38) versucht, aber da wird kein Wert zurückgegeben. Kann jemand helfen?

  

Betrifft: AW: SUMMEWENN mit NICHT-Bedingung von: Siggi
Geschrieben am: 21.01.2010 10:41:48

Hi Wolf

versuchs mal damit
=SUMMEWENN(E15:E38;"<>"&A41;D15:D38)

Grüßle Siggi


  

Betrifft: AW: SUMMEWENN mit NICHT-Bedingung von: Wolf
Geschrieben am: 21.01.2010 11:04:40

Danke, Siggi, so funktioniert es. Kannst Du mir auch sagen, was die Bedeutung der Anführungszeichen hier ist?
Und an Jowe: die betreffende Zelle bei mir ist nicht leer, ich hatte "" in der Formel nur als Textformat für Text verwendet.


  

Betrifft: AW: SUMMEWENN mit NICHT-Bedingung von: Tino
Geschrieben am: 21.01.2010 10:42:40

Hallo,
hier ein Beispiel

 BCDE
4a1 14
5a2  
6b3  
7b4  
8c5  
9c6  

Formeln der Tabelle
ZelleFormel
E4=SUMMEWENN(B4:B9;"<>b";C4:C9)


Gruß Tino


  

Betrifft: AW: SUMMEWENN mit NICHT-Bedingung von: JoWE
Geschrieben am: 21.01.2010 10:49:24

Wolf,

wenn ich Dich richtig verstehe, soll die Summe über den Bereich E15:E38 nur diejenigen Zellen enthalten, bei denen die links befindliche Vorgängerzelle z.B. nicht leer ist?
=SUMMEWENN(D15:D38;<>"";E15:E38)

Gruß,
Jochen


Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN mit NICHT-Bedingung"