Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

SUMMEWENNS - Hinweis, wenn nicht angewendet wurde

SUMMEWENNS - Hinweis, wenn nicht angewendet wurde
20.02.2015 10:49:21
Dirk
Hallo, vielleicht kann mir Jemand bei meinem Problem weiterhelfen.
Ich habe 2 Tabellen mit zwar gleicher Spaltenanzahl, aber unterschiedlicher Anzahl von Reihen. Nun möchte ich beide miteinander vergleichen bzw. Die Zieltabelle soll per SUMMEWENNS Werte aus der Ursprungstabelle übertragen, wenn Bedingung zutreffend ist. Dies funktioniert soweit, allerdings nur, wenn die Einträge in der Zieltabelle auch in der Ursprungstabelle vorhanden sind. Ansonsten wird logischer Weise nicht summiert. Das ist ja auch in Ordnung so.
Allerdings habe ich ein Problem. Ich würde gerne wissen, wenn in der Ursprungstabelle ein Eintrag vorhanden ist, der in der Zieltabelle nicht auftaucht. Dies geht nämlich leider unter. Vielleicht ist auch ein Verweis oder ein Vergleich hier angebrachter, um mir dies (zumindest) anzeigen zu lassen, welcher Eintrag in der Zieltabelle nicht auftaucht (Das würde mir schon reichen).
Stehe aber momentan auf dem Schlauch, wie ich das bewerkstelligen soll.
Wenn möglich ziehe ich eine Formellösung (kein VBA) vor.
-----------------------------
Hier mal ein Beispiel. wie ich es in etwa benutze:
Tabelle 1 (=Ausgangstabelle)
Land Artikel Hersteller Menge
Austria Kaffee X 100
Austria Gebäck Y 10
Austria Tee Z 20
Austria Zucker Z 500
Austria Alkohol Y 30
Deutschland Zucker Z 2
Deutschland Gebäck X 90
Deutschland Kaffee Y 20
Deutschland Tee X 10
Deutschland Alkohol Y 600
Belgien Tee Z 10
Belgien Zucker Y 90
Belgien Kaffee Y 1000
Belgien Alkohol X 300
Belgien Eis Y 50
Belgien Gebäck X 80
Belgien Schoko Y 2000
Tabelle2 (= Zieltabelle)
Land Artikel Hersteller Menge
Austria Alkohol Y =SUMMEWENNS($D$3:$D$19;$A$3:$A$19;A23;$B$3:$B$19;B23;$C$3:$C$19;C23)
Austria Gebäck Y
Austria Kaffee X
Austria Tee Z
Austria Zucker Z
Belgien Alkohol X
Belgien Eis Y
Belgien Gebäck X
Belgien Kaffee Y
Belgien Tee Z
Belgien Zucker Y
Deutschland Alkohol Y
Deutschland Gebäck X
Deutschland Kaffee Y
Deutschland Tee X
Deutschland Zucker Z
-----------------
(Ließ sich leider nicht besser darstellen)
Bei Tabelle2 holt er sich die Mengen mit der SUMMEWENNS aus der Tabelle1
Die Formel wird natürlich nach unten gezogen und solange die Formel erfüllt
wird, werde die Werte übertragen.
In der Tabelle1 habe ich allerdings einen Eintrag BELGIEN SCHOKO.....
Dieser wird logischer Weise nicht berücksichtigt. Wie kann ich nun festellen,
daß er nicht berücksichtigt wurde, weil er in Tabelle2 fehlt?
Freue mich über Hilfestellungen und Danke schon mal im Voraus.
P.s. Habe das Ganze auch mal als Excel Sheet angehängt.
https://www.herber.de/bbs/user/95893.xlsx

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: SUMMEWENNS - Hinweis, wenn nicht angewendet wurde
20.02.2015 10:53:26
Klaus
Hi,
zähl in Tabelle 1 nach, ob das ganze in Tabelle 2 vorkommt. In deiner Mustertabelle:
E3: =ZÄHLENWENNS(A$23:A$38;A3;B$23:B$38;B3;C$23:C$38;C3)
und runterziehen bis E19. Auf die "0" kannst du eine bedingte Formatierung legen oder sowas. Oder gleich alle 0-Werte per VBA in die Tabelle 2 rüber kopieren.
Grüße,
Klaus M.vdT.

AW: SUMMEWENNS - Hinweis, wenn nicht angewendet wurde
20.02.2015 11:04:34
Dirk
Wow, Super....
Im Prinzip genau das, was ich gesucht habe - Das reicht schon aus.
Vielen Dank Klaus M.vdT.
Gruß Dirk

Danke für die Rückmeldung! owT.
20.02.2015 11:46:53
Klaus
.
Anzeige

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige