Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
800to804
800to804
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Summenprodukt mit Textelementen

Summenprodukt mit Textelementen
14.09.2006 10:44:21
Felix
Hallo,
ich habe folgendes Problem:
Ich möchte ein Summenprodukt nutzen und dabei in einer Spalte nach bestimmten Produkttypen filtern. Also es gibt Produkte die in ihren Produktnummern verschiedene Buchstabenkombinationen (wie AA2003, AA2102, AB1982, AC3002 usw.) enthalten. Nun möchte ich die Erlöse aller Bestellungen für die verschiedenen Produktsparten z.B. AA* summieren.
=SUMMENPRODUKT(($A$1:$A$1000="AA*")*($B$1:$B$1000))
-&gt in Spalte A stehen die Produktnummern
-&gt in Spalte B stehen die Erlöse
Ein SUMMEWENN-Konstrukt kann ich nicht verwenden, da ich mehr als zwei Bedingungen abfrage. Leider scheint hier beim SUMMENPRODUKT die Funktion des "*" (Sternchens) nicht zu funktionieren. Wie muss ich meine Formel umstellen oder umformulieren, um zum Ergebnis zu kommen?
Gruß Felix

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Summenprodukt mit Textelementen
14.09.2006 10:55:45
Josef
Hallo Felix!
Tabelle1

 ABCD
1AA100176  
2AA200788 257
3AB100112  
4AC20066  
5AA100293  

Formeln der Tabelle
ZelleFormel
D2=SUMMENPRODUKT((LINKS($A$1:$A$1000;2)="AA")*($B$1:$B$1000))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp
Anzeige
AW: Summenprodukt mit Textelementen
14.09.2006 11:16:04
Felix
Vielen Dank, für die schnelle und qualifizierte Antwort. Leider gibt es bei uns auch Produktnummern, denen mehrere Sparten zugeordnet sind. Das bedeutet, dass es auch zu folgenden Konstrukten kommen kann:
"AA2100 AC"
"AA AR2122"
...
Das ist natürlich eine ziemlich üble Formatierung. Genau aus dem Grund versuche ich auch die Daten besser aufzubereiten. Um mein Problem lösen zu können, muss ich also an jeder Stelle des in der Zelle enthaltenen Textes, verschiedene Buchstabenkombinationen herausfiltern können. Gibt es da eine Möglichkeit?
Gruß Felix
AW: Summenprodukt mit Textelementen
14.09.2006 11:20:26
Josef
Hallo Felix!
Geht auch.
Tabelle1

 ABCDEF
1AA100176    
2AA200788 GesuchtErgebnis 
3AB100112 ar15 
4AC20066    
5AA100293    
6AC 1002AR2515    
7 21    
8 31    

Formeln der Tabelle
ZelleFormel
E3=SUMMENPRODUKT((ISTZAHL(SUCHEN(D3;A1:A40)))*($B$1:$B$40))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp
Anzeige
AW: Summenprodukt mit Textelementen
14.09.2006 11:24:11
Hugo
Hallo Sepp,
SUMMEWENN mit Platzhaltern geht auch.
Hugo
AW: Summenprodukt mit Textelementen
14.09.2006 13:35:54
Felix
Vielen Dank für die super Antwort! Funktioniert alles einwandfrei!
Gruß Felix

324 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige