Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen bzw. Summe aus Text und/oder Zahlen | Herbers Excel-Forum


Betrifft: Zählen bzw. Summe aus Text und/oder Zahlen von: Detlev Pautsch
Geschrieben am: 21.01.2010 00:10:16

Hallo Community

Bin ein Frischling hier und bitte auch gleich um Doppelhilfe.
Ich brauche zwei Formeln, um aus zwei bzw. drei unterschiedlichen Bedingungen ein Ergebnis zu erhalten.

zur 1 Formel:
Ich benötige die Anzahl von "XYZ" in Spalte C, nur wenn in Spalte A eine "1" steht und nur wenn in Spalte B ein "ABC" steht.

zur 2 Formel
Ich brauche die Summe in Spalte D, nur wenn in Spalte A eine "1" steht und nur wenn in Spalte B ein "ABC" steht und nur wenn in Spalte C ein "XYZ" steht.

Ich hoffe, mit der Beschreibung ist aussagekräftig genug.

Schon mal danke im Vorraus,
gruß DPautsch

  

Betrifft: Lösungen per SUMMENPRODUKT() von: NoNet
Geschrieben am: 21.01.2010 00:33:24

Hallo D.,

hier die Lösungen :

Funktion 1 : Anzahl :
=SUMMENPRODUKT((A1:A999=1)*(B1:B999="ABC")*(C1:C999="XYZ"))

Funktion 2 : Summe :
=SUMMENPRODUKT((A1:A999=1)*(B1:B999="ABC")*(C1:C999="XYZ")*(D1:D999))

Gute Nacht, NoNet


  

Betrifft: AW: Lösungen per SUMMENPRODUKT() von: Detlev Pautsch
Geschrieben am: 21.01.2010 02:32:42

danke,
werde es auf Arbeit testen und gebe natürlch auch Rückinfo


  

Betrifft: AW: Zählen bzw. Summe aus Text und/oder Zahlen von: Josef Ehrensberger
Geschrieben am: 21.01.2010 00:35:51

Hallo Detlev,

=SUMMEMPRODUKT((A1:A100=1)*(B1:B100="ABC")*(C1:C100="XYZ"))
'bzw.
=SUMMEMPRODUKT((A1:A100=1)*(B1:B100="ABC")*(C1:C100="XYZ")*D1:D100)

Gruß Sepp



  

Betrifft: AW: Zählen bzw. Summe aus Text und/oder Zahlen von: Detlev Pautsch
Geschrieben am: 21.01.2010 02:31:34

Hallo, ihr beiden,

werde die Formeln mal am Arbeitsplatz testen.
Gebe dann natürlich auch Rückinfo

Detlev


  

Betrifft: AW: Zählen bzw. Summe aus Text und/oder Zahlen von: minnimaxi
Geschrieben am: 24.01.2010 02:52:29

Hallo an beide Helfer,

habe die Formeln erfolgreich umsetzen können,nochmals danke an alle.

minnimaxi


Beiträge aus den Excel-Beispielen zum Thema "Zählen bzw. Summe aus Text und/oder Zahlen"