Microsoft Excel

Herbers Excel/VBA-Archiv

PIVOTDATENZUORDNEN mit zwei Kriterien | Herbers Excel-Forum


Betrifft: PIVOTDATENZUORDNEN mit zwei Kriterien von: Andi
Geschrieben am: 14.10.2008 12:16:38

Hallo Experten,

Ich versuch zurzeit eine Auswertung aus einer Pivot Tabelle zu erstellen, komm jedoch nicht weiter da ich zwei Kriterien in der X-achse und eins in der Y-achse berücksichtigen muss. Das heisst ich kann nicht einfach X-Achse und Y-achse mit der Pivot-tabelle abgleichen, sondern muss zwei Kennzahlen aus der X-achse berücksichtigen.

Gibts eine Möglichkeit die Formel "PIVOTDATENZUORDNEN-Formel" so zu erweitern dass ich sämtliche Kriterien berücksichtigen kann??

=WENN(ISTFEHLER(PIVOTDATENZUORDNEN("QTY";Tabelle1!$A$3;$A$1;$A2;"week";B$1));0; PIVOTDATENZUORDNEN("QTY";Tabelle1!$A$3;$A$1;$A2;"week";B$1))

Ich weiss, ich hab dieses Problem sehr kompliziert beschrieben, daher hab ich noch ein Beispiel beigelegt.

https://www.herber.de/bbs/user/56016.xls

Danke & Gruss Andi

  

Betrifft: AW: PIVOTDATENZUORDNEN mit zwei Kriterien von: Erich G.
Geschrieben am: 14.10.2008 13:34:46

Hallo Andi,
warum hast du "Bestellungen" in die Tabelle geschrieben? Hättest du kopiert, stünde da richtig "Bestellung".
Damit gehts dann:

 ABCDE
1GerätKey Figureswk10wk11wk12
2111  Lager100  150  0  
3111  Bestellung20  30  40  
4112  Lager500  600  0  
5112  Bestellung250  150  50  
6113  Lager37  27  0  
7113  Bestellung200  300  10  
8114  Lager0  0  0  
9114  Bestellung0  0  0  
10115  Lager0  0  0  
11115  Bestellungen0  0  0  

Formeln der Tabelle
ZelleFormel
C2=WENN(ISTFEHLER(PIVOTDATENZUORDNEN("QTY";Pivot!$A$3;"Gerät";$A2;"Key Figure";$B2;"Woche";C$1)); 0; PIVOTDATENZUORDNEN("QTY";Pivot!$A$3;"Gerät";$A2;"Key Figure";$B2;"Woche";C$1))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: PIVOTDATENZUORDNEN mit zwei Kriterien von: Erich G.
Geschrieben am: 14.10.2008 13:40:30

Hallo nochmal,
mit "Key Figure" statt "Key Figures" in B1 klappt es auch so:

 ABCDE
1GerätKey Figurewk10wk11wk12
2111  Lager100  150  0  

Formeln der Tabelle
ZelleFormel
C2=WENN(ISTFEHLER(PIVOTDATENZUORDNEN("QTY";Pivot!$A$3;$A$1;$A2;$B$1;$B2;"Woche";C$1)); 0; PIVOTDATENZUORDNEN("QTY";Pivot!$A$3;$A$1;$A2;$B$1;$B2;"Woche";C$1))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: PIVOTDATENZUORDNEN mit zwei Kriterien von: Andi
Geschrieben am: 14.10.2008 13:57:05

Hey, super!! funktioniert! Dankevielmals


  

Betrifft: AW: PIVOTDATENZUORDNEN mit zwei Kriterien von: AndrRo
Geschrieben am: 14.10.2008 13:53:42

Hallo Andi,

ich würde den Zwischenschritt mit der PivotTabelle nicht machen und die Tabelle direkt aus den Rohdaten füllen:

C2=SUMMENPRODUKT(($B2=Rohdaten!$B$2:$B$16)*(Auswertung!$A2=Rohdaten!$A$2:$A$16)*(Auswertung!C$1=Rohdaten!$C$2:$C$16)*(Rohdaten!$D$2:$D$16))

Die Formel kannst du dann in die anderen Felder kopieren.

gruss

AndrRo


Beiträge aus den Excel-Beispielen zum Thema "PIVOTDATENZUORDNEN mit zwei Kriterien"