Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
572to576
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
572to576
572to576
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Sverweis - Summe aus allen gefundenen Werten?
23.02.2005 22:02:31
Thorsten
Guten Abend,
Brauche wieder mal Hilfe
Mit nachstehender Formel finde ich den 1.Wert.
'=SVERWEIS(C3;Bank!$I$2:$R$999;VERGLEICH($F$1;Bank!$I$2:R2;0);0)
Nun brauch ich den aber nicht, sondern die Summe aller entsprechenden Werte mit gleichem Namen.
Kann man die Formel entsprechend erweitern? oder muss man dafür
eine andere ansetzen?
Für Hilfe, Hinweise besten Dank
Gruß Thorsten

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Sverweis - Summe aus allen gefundenen Werten?
Reinhard
Hi Thorsten,
in B steh z.B die Anzahl pro Artikelnummer, die Artikelnummern stehen in A stehen,jetzt steht in C3 die Artikelnummer x und du willst die Gesamtsumme aller Artikel haben die x in Spalte A heissen:
=SUMME(WENN(A1:A100=C3;B1:B100))
und dies als Matrixformel eingeben mit Strg+Shift+Enter, so dass es so in der elle erscheint:
{=SUMME(WENN(A1:A100=C3;B1:B100))}
Gruß
Reinhard
A bisserl kompliziert, oder?
Boris
Hi Reinhard,
meine Excelversion stellt dafür ne Standardfunktion zur Verfügung: SUMMEWENN()
;-))
Grüße Boris
AW: A bisserl kompliziert, oder?
@
Hi Boris,
was meinst du?
Die Formel oder die Hilfe von Reinhard war zu gut für ein Laien?
Gruß Thorsten
Anzeige
Die Formel war zu kompliziert...
Boris
Hi Thorsten,
Reinhard hat die Standardfunktion SUMMEWENN() mit einem {SUMME(WENN...-Array} nachgebaut. Funktioniert natürlich auch - ist aber unnötig kompliziert und bei großen Bereichen respektive häufigem Vorkommen um Lichtjahre langsamer.
Grüße Boris
Besten Dank - funktioniert super
Thorsten
Hallo Reinhard,
hat biss`l gedauert.
Funktioniert Klasse.
Besten Dank
Gruß Thorsten
AW: Sverweis - Summe aus allen gefundenen Werten?
Hübi
Hi Thorsten,
meinst du es so
Tabelle1
 ABCDEFGH
1 JanFebMrzApr Summe vonMrz
2Mo6847  Di
3Di81109  20
4Mi2298   
5Mo10514   
6Di36104   
Formeln der Tabelle
H3 : =SUMMEWENN(A2:A100;H2;INDIREKT(ADRESSE(2;VERGLEICH(H1;$A$1:$E$1;0))&":"&ADRESSE(100;VERGLEICH(H1;$A$1:$E$1;0))))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Hübi
Anzeige
Nur so zum Spass...
Boris
Hi Hübi,
...3 weitere (verkürzte) Varianten - und alle arrayfrei ;-)
=SUMMEWENN(A:A;H2;BEREICH.VERSCHIEBEN(A:A;;VERGLEICH(H1;B1:E1;)))
=SUMMENPRODUKT((A2:A6=H2)*INDEX(B2:E6;;VERGLEICH(H1;B1:E1;)))
=SUMMENPRODUKT((A2:A6=H2)*(B1:E1=H1)*B2:E6)
Grüße Boris
AW: Nur so zum Spass...
Hübi
Hi Boris,
danke - warum einfach, wenn´s umständlich auch geht ;-))
Für Thorsten war aber schon die Lösung von Reinhard ausreichend.
Gruß Hübi
oT. @ alle - Besten Dank, habt alle geholfen
Thorsten
o.T.

121 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Infobox zum Thema

EXCEL - Einsatz der SUMMEWENN-Funktion


Inhaltsverzeichnis

  1. Was ist die SUMMEWENN-Funktion?
  2. Einsatzzweck
  3. Anleitung zur Umsetzung
  4. Anwendungsbeispiele aus der Praxis
  5. Tipps
  6. Verwandte Funktionen
  7. Zusammenfassung

Was ist die SUMMEWENN-Funktion?

SUMMEWENN im Überblick

Die SUMMEWENN-Funktion in Excel summiert Werte in einem Bereich basierend auf einem einzelnen Kriterium.

Unterschied zu SVERWEIS

Während SVERWEIS dir den ersten passenden Wert aus einem anderen Bereich zurückgibt, ermöglicht dir SUMMEWENN, alle Werte zu summieren, die ein bestimmtes Kriterium erfüllen.


Einsatzzweck

Datenzusammenfassung

Wenn du eine Tabelle mit wiederkehrenden Einträgen hast und wissen möchtest, wie sich bestimmte Werte aufsummieren, ist SUMMEWENN das richtige Werkzeug.

Einfacher als Pivot-Tabellen

Für einfache Zusammenfassungen von Daten kann SUMMEWENN schneller und einfacher sein als das Erstellen einer Pivot-Tabelle.


Anleitung zur Umsetzung

Du möchtest die Summe aller Werte in einem bestimmten Bereich (z.B. Bank!$R$2:$R$999) für Einträge, die einem Kriterium entsprechen (z.B. einem Namen in C3). Die SUMMEWENN-Funktion ist hierfür ideal.

Die Formel könnte so aussehen:

=SUMMEWENN(Bank!$I$2:$I$999;C3;Bank!$R$2:$R$999)
  • Der Bereich Bank!$I$2:$I$999 ist der Bereich, in dem nach dem Kriterium gesucht wird.
  • C3 ist das Kriterium (in diesem Fall der Name).
  • Bank!$R$2:$R$999 ist der Bereich der Werte, die summiert werden sollen, wenn das Kriterium erfüllt ist.

Anwendungsbeispiele aus der Praxis

  1. Budgetplanung: Verwende SUMMEWENN, um Ausgaben für bestimmte Kategorien über mehrere Monate hinweg zu summieren.
  2. Lagerverwaltung: Ermittle die Gesamtmenge eines bestimmten Artikels, der mehrfach in einer Liste auftaucht.

Tipps

  • Achte darauf, dass die Bereiche in deiner SUMMEWENN-Formel dieselbe Anzahl von Zeilen und Spalten haben, sonst erhältst du einen Fehler.
  • Wenn du mehrere Kriterien gleichzeitig berücksichtigen möchtest, ziehe die Verwendung von SUMMEWENNS in Betracht.

Verwandte Funktionen

  • SUMMEWENNS: Ermöglicht die Summierung basierend auf mehreren Kriterien.
  • ZÄHLENWENN: Zählt die Anzahl der Zellen in einem Bereich, die ein bestimmtes Kriterium erfüllen.

Zusammenfassung

SUMMEWENN ist ein leistungsstarkes Werkzeug in Excel, das es dir ermöglicht, Werte basierend auf einem Kriterium zu summieren. Es bietet eine einfachere Alternative zu Pivot-Tabellen für einfache Datenzusammenfassungen und ist insbesondere nützlich, wenn du wiederkehrende Einträge in deiner Tabelle hast. Mit der richtigen Anwendung kannst du schnell und effizient die gewünschten Summen erhalten.

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige