Sverweis - Summe aus allen gefundenen Werten?

Bild

Betrifft: Sverweis - Summe aus allen gefundenen Werten?
von: Thorsten W.
Geschrieben am: 23.02.2005 22:02:31
Guten Abend,

Brauche wieder mal Hilfe
Mit nachstehender Formel finde ich den 1.Wert.
'=SVERWEIS(C3;Bank!$I$2:$R$999;VERGLEICH($F$1;Bank!$I$2:R2;0);0)
Nun brauch ich den aber nicht, sondern die Summe aller entsprechenden Werte mit gleichem Namen.
Kann man die Formel entsprechend erweitern? oder muss man dafür
eine andere ansetzen?
Für Hilfe, Hinweise besten Dank
Gruß Thorsten

Bild

Betrifft: AW: Sverweis - Summe aus allen gefundenen Werten?
von: Reinhard
Geschrieben am: 23.02.2005 22:21:41
Hi Thorsten,
in B steh z.B die Anzahl pro Artikelnummer, die Artikelnummern stehen in A stehen,jetzt steht in C3 die Artikelnummer x und du willst die Gesamtsumme aller Artikel haben die x in Spalte A heissen:
=SUMME(WENN(A1:A100=C3;B1:B100))
und dies als Matrixformel eingeben mit Strg+Shift+Enter, so dass es so in der elle erscheint:
{=SUMME(WENN(A1:A100=C3;B1:B100))}
Gruß
Reinhard
Bild

Betrifft: A bisserl kompliziert, oder?
von: Boris
Geschrieben am: 23.02.2005 22:29:42
Hi Reinhard,
meine Excelversion stellt dafür ne Standardfunktion zur Verfügung: SUMMEWENN()
;-))
Grüße Boris
Bild

Betrifft: AW: A bisserl kompliziert, oder?
von: @ Boris
Geschrieben am: 23.02.2005 22:53:55
Hi Boris,
was meinst du?
Die Formel oder die Hilfe von Reinhard war zu gut für ein Laien?
Gruß Thorsten
Bild

Betrifft: Die Formel war zu kompliziert...
von: Boris
Geschrieben am: 23.02.2005 22:56:31
Hi Thorsten,
Reinhard hat die Standardfunktion SUMMEWENN() mit einem {SUMME(WENN...-Array} nachgebaut. Funktioniert natürlich auch - ist aber unnötig kompliziert und bei großen Bereichen respektive häufigem Vorkommen um Lichtjahre langsamer.
Grüße Boris
Bild

Betrifft: Besten Dank - funktioniert super
von: Thorsten W.
Geschrieben am: 23.02.2005 22:38:29
Hallo Reinhard,
hat biss`l gedauert.
Funktioniert Klasse.
Besten Dank
Gruß Thorsten
Bild

Betrifft: AW: Sverweis - Summe aus allen gefundenen Werten?
von: Hübi
Geschrieben am: 23.02.2005 22:33:33
Hi Thorsten,
meinst du es so
Tabelle1
 ABCDEFGH
1 JanFebMrzApr Summe vonMrz
2Mo6847  Di
3Di81109  20
4Mi2298   
5Mo10514   
6Di36104   
Formeln der Tabelle
H3 : =SUMMEWENN(A2:A100;H2;INDIREKT(ADRESSE(2;VERGLEICH(H1;$A$1:$E$1;0))&":"&ADRESSE(100;VERGLEICH(H1;$A$1:$E$1;0))))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hübi
Bild

Betrifft: Nur so zum Spass...
von: Boris
Geschrieben am: 23.02.2005 22:51:40
Hi Hübi,
...3 weitere (verkürzte) Varianten - und alle arrayfrei ;-)
=SUMMEWENN(A:A;H2;BEREICH.VERSCHIEBEN(A:A;;VERGLEICH(H1;B1:E1;)))
=SUMMENPRODUKT((A2:A6=H2)*INDEX(B2:E6;;VERGLEICH(H1;B1:E1;)))
=SUMMENPRODUKT((A2:A6=H2)*(B1:E1=H1)*B2:E6)
Grüße Boris
Bild

Betrifft: AW: Nur so zum Spass...
von: Hübi
Geschrieben am: 23.02.2005 23:00:09
Hi Boris,
danke - warum einfach, wenn´s umständlich auch geht ;-))
Für Thorsten war aber schon die Lösung von Reinhard ausreichend.
Gruß Hübi
Bild

Betrifft: oT. @ alle - Besten Dank, habt alle geholfen
von: Thorsten W.
Geschrieben am: 23.02.2005 23:01:43
o.T.
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Sverweis - Summe aus allen gefundenen Werten?"