sverweis mit mehreren ergebnissen

Bild

Betrifft: sverweis mit mehreren ergebnissen
von: lau
Geschrieben am: 26.07.2015 13:40:51

Hallo zusammen,
ich habe für einen S-verweis mehrere Ergebnissen.
Würde gerne, dass alle Ergebnissen als Summe angezeigt werden.
Spalte A Spalte B Spalte C
810 820 617,3 Euro
820 820 1000 Euro
830 840 2000 Euro
840 840 3000 Euro
Wenn ich als Sverweis(A2; B:C; 2;0) bilde, dann kommt als Lösung 617,3 Euro und nicht die Summe raus.
Mit dem Index/vergleich Formel komme ich irgendwie nicht weiter.
Hat jmd. einen Vorschlag?
Vielen Dank im Voraus.
lau

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: Hajo_Zi
Geschrieben am: 26.07.2015 13:43:58
Für Summe hätte ich Summewenn benutzt.


Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: lau
Geschrieben am: 26.07.2015 14:32:04
Hallo Hajo,
wenn ich die summewenn(A:C;A1;C:C) bilde kommt ein falsches Ergebnis raus.
Stimmt die Formel?
viele Grüße

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: lau
Geschrieben am: 26.07.2015 14:39:03
Hallo Hajo,
ich glaube ich brauche zusätzlich einen sverweis, da ich erst suchen muss, ob in Spalte B die Nr. sich aus Spalte A befindet. Wenn ja und dies öfters vorkommt, dann soll dies über spalte C summiert werden.
hoffe ich habe mich einigermaßen deutlich ausgedrückt.
Viele Grüße

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: Hajo_Zi
Geschrieben am: 26.07.2015 14:42:50

Tabelle3

 ABCDE
1810820617,3Euro1617,3
28208201000Euro 
38308402000Euro 
48408403000Euro 

verwendete Formeln
Zelle Formel Bereich N/A
E1=SUMMEWENN(B:B;B1;C:C)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.07 einschl. 64 Bit


Gruß Hajo

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: lau
Geschrieben am: 26.07.2015 15:27:16
das hilft sehr weiter.
vielen dank.

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: lau
Geschrieben am: 26.07.2015 15:36:03
Hallo Hajo,
habe doch noch eine verwandte Frage.
Mein Sverweis(A;A:B;1;0) funktioniert nicht. Glaube es liegt irgendwie an der Exceldatei die textcodiert ist. Umwandlung in Zahlenformat hilft mir nicht. Glätten-Fkt. auch nicht.
Hatte die Idee über Index(A:A;vergleich(A1;B:B;0) den s-verweis zu ersetzen.
Klappt aber auch nicht.
Hast du vielleicht hierzu eine Idee?

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: lau
Geschrieben am: 26.07.2015 15:42:11
hab die Werte mit 1 multipliziert. Jetzt funktioniert der sverweis teilweise. manche werte werden aber immernoch nicht gefunden.

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: Hajo_Zi
Geschrieben am: 26.07.2015 15:44:02
bei mir gejht es, Deine Datei sehe ich nicht.

Tabelle3

 ABCDEF
1810820617,3Euro1617,3820
28208201000Euro 820
38308402000Euro  
48408403000Euro  

verwendete Formeln
Zelle Formel Bereich N/A
E1=SUMMEWENN(B:B;B1;C:C)  
F1=SVERWEIS(A;A:B;1;0)  
F2=A  

definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
A=Tabelle3!$A$2 =Tabelle3!R2C1
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.07 einschl. 64 Bit


Gruß Hajo

Bild

Betrifft: AW: sverweis mit mehreren ergebnissen
von: lau
Geschrieben am: 26.07.2015 17:10:35
ja klappt nicht. ist irgendwie ganz merkwürdig.
Scheint ein Formatproblem zu sein.
Danke trotzdem.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "sverweis mit mehreren ergebnissen"