Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Ähnlich Sverweis Bereich von bis...

Ähnlich Sverweis Bereich von bis...
bis...
Hallo und schönen Guten Abend zusammen,
leider bisher erfolglos bei meiner Suche nach einer passenden Formel. Deshalb wende ich mich an die Experten in diesem Forum.
Beschreibung:
Ich habe ca. 100 Zeilen, in denen in Spalte A und Spalte B jeweils 5 stellige Zahlen enthalten sind.
Diese stellen jeweils einen Bereich pro Zeile dar, (also von - bis). Beispiel:
1. Zeile: 11102 | 11224
2. Zeile: 22004 | 25222
usw.
Nun sollen 24.000 5-stellige Zahlen aus einer anderen Tabelle geprüft werden, ob diese in einer dieser 100 Zeilen enthalten sind (größer gleich Zahl in A1 und kleiner gleich Zahl in B1) . Z.Bsp. die erste Zahl, die überprüft werden soll, ist die 11144. Diese liegt in diesem Beispiel im Bereich der ersten Zeile, deshalb soll der Wert aus Spalte C der entsprechenden Zeile ausgegeben werden.
Hat jemand eine Idee?
Vielen Dank und schöne Grüße
Ari

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Ähnlich Sverweis Bereich von bis...
14.12.2011 19:57:06
bis...
Hallo Ari,
angenommen Deine zu überprüfende Zahl steht in D1. Dann diese Formel:
=WENN(SUMMENPRODUKT((D1=$A$1:$A$100));"ok";"fehlt")
(Bereich anpassen)
Habe ich Dich richtig verstanden?
Klappt es?
Gruß
Uwe
(:o)
AW: Ähnlich Sverweis Bereich von bis...
14.12.2011 21:08:49
bis...
SORRY,
den letzten Teilj- den Wert aus Spalte C ausgeben - hatte ich überlesen.
Gruß
Uwe
(:o)
AW: Ähnlich Sverweis Bereich von bis...
14.12.2011 21:56:47
bis...
danke trotzdem fürs mit überlegen, die richtige Formel ist jetzt gefunden :-)
Viele Grüße Ari
AW: Ähnlich Sverweis Bereich von bis...
14.12.2011 20:27:56
bis...

Hallo Ari,
Tabelle2

 ABCDEFGHI
11110211224A    11144A
22200425222B      
3         

Formeln der Tabelle
ZelleFormel
I1{=WENN(SUMMENPRODUKT((H1>=A1:A1000)*(H1<=B1:B1000))>0;INDEX(C1:C1000;MIN(WENN((H1>=A1:A1000)*(H1<=B1:B1000); ZEILE(1:1000)))); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

« Gruß Sepp »

Anzeige
AW: Ähnlich Sverweis Bereich von bis...
14.12.2011 20:58:28
bis...
Hallo Sepp,
das ist die Lösung! Perfekt.
Vielen Dank und schöne Grüße
Ari
AW: Ähnlich Sverweis Bereich von bis...
14.12.2011 20:31:10
bis...
Hallo,
gesuchte Zahl in D2
Matrixformel:
{=INDEX(C2:C100;MIN(WENN((A2:A100=D2);ZEILE(2:100);""))-1)}
Gruß
Rudi
AW: Ähnlich Sverweis Bereich von bis...
14.12.2011 22:20:40
bis...
Hallo Rudi,
vielen Dank für deine Mithilfe.
So herum funktioniert es auch.
Gute Nacht
Ari

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige