Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
232to236
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
232to236
232to236
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Wenn zwischen dann sonst ....

Wenn zwischen dann sonst ....
18.03.2003 19:02:57
Klaus K.
Hallo,
wie kann ich folgendes Problem lösen?
In A1 können verschiedene Zahlenwerte stehen.
Nun möchte ich feststellen ob in A1 ein Wert zwischen
1 und 10 (=1), 11 und 100 (=2), 101 und 1000 (=3), über 1000 (=4), oder 0 (=0)steht.
Hat jemand einen Lösungsansatz für mich ?
Am besten als Formel.
Danke Euch
Gruss
Klaus

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Wenn zwischen dann sonst ....
18.03.2003 19:22:53
PeterW

Hallo Klaus,

probier es beispielsweise so:
=WENN(A1=0;0;WENN(A1<=10;1;WENN(A1<=100;2;WENN(A1<=1000;3;4))))

Gruß
Peter

Re: Wenn zwischen dann sonst ....
18.03.2003 19:26:57
Christoph

Hallo Klaus

hier die Formel: in B1 eingeben:
=WENN(A1>1000;4;WENN(A1>100;3;WENN(A1>10;2;WENN(A1>=1;1;0))))

Gruß
Christoph

Re: Wenn zwischen dann sonst ....
18.03.2003 19:31:07
Holger Levetzow

vielleicht mal ganz witzig:

=WENN(A1=0;0;LÄNGE(A1-1))

kannst auch schön auf 10.000, 100.000 ... ausdehnen.

Holger

Re: Wenn zwischen dann sonst ....
18.03.2003 19:34:19
Holger Levetzow

und sollten es nicht nur natürliche Zahlen sein:

=WENN(A1=0;0;LÄNGE(GANZZAHL(A1)-1))

Holger


Re: Wenn zwischen dann sonst ....
18.03.2003 19:34:59
th.heinrich

hallo Holger,

habe mich auch gerade durch die wenns geklammert, andere waren schneller. Deine idee ist allerdings genial.

gruss thomas

Anzeige
Danke Euch. Super Idee mit =Länge()... o.T.
18.03.2003 19:48:57
Klaus K.

.

330 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige