Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn Zahl in Spalte, dann definierte Zelle übern.

Wenn Zahl in Spalte, dann definierte Zelle übern.
30.01.2014 14:02:34
Martin
Hallo Experten,
ich komme hier nicht mehr weiter.
Wenn in einer Spalte die Zahl 1 geschrieben wird, dann soll der Inhalt der gleichen Zeile von Spalte B in eine Tabelle übertragen werden.
Vielleicht verständlicher anhand eines Beispiels.
Userbild
In meinem Screenshot steht in A6 eine 1 somit soll das "Hallo" in B6 in eine Tabelle übertragen werden. Auch in A10 steht eine 1 und so soll ebenfalls das Hallo in B10 übertragen werden.
Ich bitte um Hilfe!
Vielen Dank im Voraus,
Martin

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Das kann man permanent mit Formel machen, ...
30.01.2014 14:10:26
Luc:-?
…Martin,
oder einmalig im Moment des Eintrags der 1 per VBA-Ereignisprozedur.
Gruß Luc :-?

AW: Das kann man permanent mit Formel machen, ...
30.01.2014 14:24:01
Martin
Erstmal vielen Dank für die Antwort! :)
Die Formel ist genau das Problem.
Von VBA mal ganz zu schweigen!

eine Formellösung ....
30.01.2014 17:23:10
neopa
Hallo Martin,
... könnte z.B. so aussehen (Formel nach unten kopieren):
Tabelle2

 A
1Hallo ?
2Hallo_4
3Hallo_8
4Hallo_9
5 

Formeln der Tabelle
ZelleFormel
A2{=WENN(ZEILE(A1)>ZÄHLENWENN(Tabelle1!A:A;1); "";INDEX(Tabelle1!B:B;KKLEINSTE(WENN(Tabelle1!A$3:A$99=1;ZEILE($3:$99)); ZEILE(A1))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Tabelle1

 AB
1  
2  
39Hallo_1
45Hallo_2
54Hallo_3
61Hallo_4
76Hallo_5
82Hallo_6
93Hallo_7
101Hallo_8
111Hallo_9
125Hallo_10
13  


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...
Anzeige

412 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige