Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

wenn leer dann kein WERT

wenn leer dann kein WERT
06.12.2017 11:13:20
Robert
Hallo,
Ich habe eine Schichtzeitenseite in die Ich meine Arbeitszeiten Eintrage und es mir dann rechts davon die Stunden anzeigt. Nun habe ich weiter Rechts noch Nachtzuschläge mit eingebaut. Diese Funktionieren auch aber es zeigt mir bei den Tagen wo ich nicht Arbeite #WERT! an da in diesen Leeren Spalten zwar eine Formel hinterlegt ist aber ja keine Zeit von mir.
Tag, Dat., Schicht, Beginn, Ende, NachtArbZeit
Sonntag 01 #WERT!~f~
Montag 02 Früh 04:40 13:00 1:20
Wie kann ich das machen das Sie leer bleibt wenn keine Schicht eingetragen ist.
Die jetzige Formel lautet:
~f~ =MAX(0;MIN(Voreinstellungen!$C$33+(Voreinstellungen!$B$33>Voreinstellungen!$C$33);F4+(E4>F4))-MAX(Voreinstellungen!$B$33;E4))+MAX(;(MIN(Voreinstellungen!$C$33;F4+(E4>F4))-E4)*(Voreinstellungen!$B$33>Voreinstellungen!$C$33))+MAX(;MIN(Voreinstellungen!$C$33+(Voreinstellungen!$B$33>Voreinstellungen!$C$33);F4+0)-Voreinstellungen!$B$33)*(E4>F4)
Danke

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: wenn leer dann kein WERT
06.12.2017 11:24:44
Burak
einfach eine bedingung mit einfügen "=WENN(A1 = ""; E1 = ""; Rest deines Codes)
AW: wenn leer dann kein WERT
06.12.2017 11:52:36
Robert
Hallo,
Danke für den Hinweis. Das geht aber nicht da ja in der Zeile wo es schauen soll ja schon ein Code hinterlegt ist.
Dieser hier
=WENN(ISTFEHLER(SVERWEIS(D4;Voreinstellungen!$D$19:$E$39;2;0));"";SVERWEIS(D4;Voreinstellungen!$D$19:$E$39;2;0))
Ich hänge mal die Exel Datei mit an zum besseren Verstehen.
https://www.herber.de/bbs/user/118139.zip
=WENNFEHLER(DeineFormel; "") owT
06.12.2017 12:27:45
Rudi
AW: =WENNFEHLER(DeineFormel; "") owT
06.12.2017 12:50:44
Robert
Die jetzige Formel lautet:
=MAX(0;MIN(Voreinstellungen!$C$33+(Voreinstellungen!$B$33>Voreinstellungen!$C$33);F4+(E4>F4))-MAX(Voreinstellungen!$B$33;E4))+MAX(;(MIN(Voreinstellungen!$C$33;F4+(E4>F4))-E4)*(Voreinstellungen!$B$33>Voreinstellungen!$C$33))+MAX(;MIN(Voreinstellungen!$C$33+(Voreinstellungen!$B$33>Voreinstellungen!$C$33);F4+0)-Voreinstellungen!$B$33)*(E4>F4)
Die neue Formel lautet:
~f~ =WENNFEHLER(=MAX(0;MIN(Voreinstellungen!$C$33+(Voreinstellungen!$B$33>Voreinstellungen!$C$33);F4+(E4>F4))-MAX(Voreinstellungen!$B$33;E4))+MAX(;(MIN(Voreinstellungen!$C$33;F4+(E4>F4))-E4)*(Voreinstellungen!$B$33>Voreinstellungen!$C$33))+MAX(;MIN(Voreinstellungen!$C$33+(Voreinstellungen!$B$33>Voreinstellungen!$C$33);F4+0)-Voreinstellungen!$B$33)*(E4>F4);"")
Excel sagt: Formel Enthält einen Fehler?
Anzeige
AW: =WENNFEHLER(DeineFormel; "") owT
06.12.2017 13:07:15
SF
Hola,
Excel zeigt dir sogar wo der Fehler ist. Vor Max kommt kein = mehr.
Gruß,
steve1da

392 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige