Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählenwenns... Leere Zelle

Zählenwenns... Leere Zelle
13.02.2009 10:55:00
UweD
Hallo
Ich habe 2 Tabellen, wo (fast) täglich 1. Produktionsrückstände und 2. Fehler aufgelistet sind.
Es kommt vor, daß eine Tabelle mal an einem Tag nicht abgefragt und gefüllt wird.
In der Zusammenfassung wird dieser Tag dann mit 0 gewertet. Wie stelle ich es an, daß an diesem Tag die Zelle dann LEER bleibt.
Beispiel wären die gelben Zellen. Der 06.02 und 13.02 sind in Tabelle FT nicht vorhanden.
Auswertung
 ABCD
1DatumRS FT
202.02.20092 2
303.02.20092 3
404.02.20091 1
505.02.20092 3
606.02.20092 0
709.02.20094 3
810.02.20094 2
911.02.20093 1
1012.02.20092 3
1113.02.20093 0
12    
13Summe25 18
Formeln der Tabelle
B2 : =ZÄHLENWENNS(RS!$A:$A;Auswertung!$A2;RS!$B:$B;"""""")
D2 : =ZÄHLENWENNS(FT!$A:$A;Auswertung!$A2;FT!$B:$B;"""""")
B13 : =SUMME(B1:B12)
D13 : =SUMME(D1:D12)
 
RS
 AB
1DatumAFTNUM
202.02.2009124.344.908
302.02.2009124.461.121
403.02.2009124.438.875
503.02.20091.244.611.249
604.02.2009124.438.875
705.02.2009124.482.799
805.02.2009124.461.515
906.02.2009124.461.576
1006.02.2009124.461.488
1109.02.2009124.438.789
1209.02.2009124.501.169
1309.02.2009124.461.576
1409.02.2009124.461.488
1510.02.2009124.520.752
1610.02.2009124.520.828
1710.02.2009124.520.833
1810.02.2009124.520.868
1911.02.2009124.542.694
2011.02.2009124.520.653
2111.02.2009124.501.217
2212.02.2009124.520.835
2312.02.2009124.520.840
2413.02.2009124.722.824
2513.02.2009124.520.843
2613.02.2009124.520.894
 
FT
 AB
1DatumArtikelnr.
202.02.2009174.117.381.710
302.02.200917.411.781.150
403.02.20091.741.317.600
503.02.200917.917.318.801
603.02.20091.795.176.501
704.02.200917.106.301.715
805.02.200917.413.381.705
905.02.200917.951.799.415
1005.02.200981.717.610.093
1109.02.200917.106.301.715
1209.02.20091.710.651.380
1309.02.20091.710.655.531
1410.02.20091.793.531.700
1510.02.2009817.117.664.017
1611.02.200917.106.871.715
1712.02.200917.951.798.341
1812.02.2009179.517.983.417
1912.02.2009817.117.660.170
 

! Achtung Zählenwenns() aus Excel 2007 (mit mehreren Bedingungen)
Gruß UweD

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zählenwenns... Leere Zelle
13.02.2009 11:03:00
Bertram
Hallo Uwe,
wenn ich das richtig verstehe, sollte es doch mit Extras-Optionen-Register Ansicht- Nullwerte das Häkchen rausnehmen, getan sein.
Gruß
Bertram
AW: Zählenwenns... Leere Zelle
13.02.2009 11:05:00
Michel
Hallo,
und es soll dann die Zelle leer sein, richtig? und KEINE 0 erhalten
das geht mit eine Wenn-Bedingung
Wenn(Deine Formel=0;"";deine Formel
oder habe ich es falsch verstanden
0-Werte ausblenden
13.02.2009 11:12:00
NoNet
Hallo Uwe,
zum "Ausblenden" der Null-Werte kannst Du folgendes Benutzerdefiniertes Format de rZellen verwenden ("Format - Zellen formatieren - Benutzerdefiniert - Typ" : Standard;Standard;)
Oder Du überprüfst das Ergebnis mit einer simplen WENN-Funktion :
=WENN(ZÄHLENWENNS(...)=0;"";ZÄHLENWENNS(...))
Gruß, NoNet
Anzeige
Danke an alle
13.02.2009 11:59:00
UweD
Hallo
Manchmal ist die Lösung so einfach...
Danke für die Hinweise.
Ich werde die =WENN(ZÄHLENWENNS(...)=0;"";ZÄHLENWENNS(...)) verwenden
Gruß UweD

324 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige