Formel (standard?) Wenn, Dann, Sonst



Excel-Version: 2000
nach unten

Betrifft: Formel (standard?) Wenn, Dann, Sonst
von: Niko
Geschrieben am: 02.05.2002 - 22:41:27

Hallo!

Ich möchte eine Liste von Zahlen entsprechend formatiert haben:
Er soll aus Nachkommazahlen die zwischen 2",00" und 2",49" immer auf ",50" runden. Aus 2",51" bis 2",89" immer ",90" machen.

Ergebnis: 2,50 und 2,90 (die Vorkommazahlen sollen als "variablen" betrachtet werden.)

Wenn die gesamte Zahl jedoch höher als 149,99 ist, dann soll immer auf die nächste ganze Zahl aufgerundet werden.

Meine Formel (leider nicht Excel kompatibel):
(=WENN B1 <,5 AUFRUNDEN ,5; WENN B1 >,5 AUFRUNDEN ,9; WENN B1 >149,99 AUFRUNDEN GANZZAHL) ...wie gesagt leider NICHT Excel kompatibel. :-)

Kennt jemand von euch eine Excel Kompatible Formel??? :-) Danke

nach oben   nach unten

So muesste es passen ...
von: Volker Croll
Geschrieben am: 02.05.2002 - 23:13:06

Hallo Niko,

teste mal:

=WENN(B1=150;150;WENN(B1<149,99;WENN(B1-GANZZAHL(B1)<=0,5;GANZZAHL(B1)+0,5;WENN(B1-GANZZAHL(B1)>0,5;GANZZAHL(B1)+0,9));GANZZAHL(B1)+1))

Hoffe, ich habe an alle Sonderfaelle (z.B. B1=150) gedacht.

Gruss Volker

nach oben   nach unten

Re: :---))))))))))))
von: Niko
Geschrieben am: 03.05.2002 - 11:43:43

Vielen Dank! Hat alles geklappt und auch Die "Sonderfälle" sind in Deinem posting berücksichtigt. Grossen Dank uuuunnnndddd EXCELLENT!

Grüsse aus Berlin, Niko


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Formel (standard?) Wenn, Dann, Sonst"