Wenn Zelle leer, dann Formel einfügen

Bild

Betrifft: Wenn Zelle leer, dann Formel einfügen
von: mic13
Geschrieben am: 07.10.2015 13:39:50

Hallo
Ich habe ein Problem mit einem Formular mit Blattschutz, das ich nicht lösen kann und zwar folgendes:
In der verbundenen Zelle AY12 (AY12:BG1) steht eine Formel drin, welche den Vornamen ausweist, wenn er das Kurzzeichen im Sverweis findet und sonst leer lässt:
=WENN($AT12="";"";WENN(ISTFEHLER(SVERWEIS($AT12;Daten!$M$3:$S$41;2;FALSCH));"";SVERWEIS($AT12; Daten!$M$3:$S$41;2;FALSCH)))
Wenn nun aber das Kurzzeichen in AT12 nicht vorhanden ist, muss man manuell den Vornamen erfassen , d.h. die verbundene Zelle AY12 mit der oben erwähnten Formel ist nicht gesperrt. Das funktioniert soweit so gut, nur wenn man den Vornamen manuell einträgt, wird natürlich die Formel gelöscht. Ich möchte aber, dass wenn die Zelle leer ist (d.h. wenn man die manuellen Eingaben wieder löscht), dass dann wieder die Formel drin steht.
Habe schon zwei Formeln gefunden, die aber nicht funktionieren, weil ich sehr wahrscheinlich etwas nicht richtig mache. kann mir jemand sagen, welche Formel ich im VBA eingeben muss?
Herzlichen Dank für Eure Hilfe :)
Grüsse,
Claudia

Bild

Betrifft: AW: Wenn Zelle leer, dann Formel einfügen
von: mic13
Geschrieben am: 08.10.2015 06:03:24
Kann niemand helfen?

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn Zelle leer, dann Formel einfügen"