Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 22:07:02
25.06.2024 21:01:55
25.06.2024 19:21:44
Anzeige
Archiv - Navigation
1480to1484
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn Zelle nicht vorhanden, dann Zeile löschen

Wenn Zelle nicht vorhanden, dann Zeile löschen
05.03.2016 15:48:08
Thomas
Hallo alle zusammen,
ich habe eine Exceldatei mit zwei Datenblätter.
Ich möchte aus Datenblatt 1 alle Zeilen löschen, die im Datenblatt 2 nicht erscheinen.
Ausgang
Datenblatt 1:
A B C
1 2 2
5 2 2
2 2 2
Datenblatt 2:
A B C
5 2 2
2 2 2
------------------------
Ergebnis
Datenblatt 1:
A B C
5 2 2
2 2 2
Datenblatt 2:
A B C
5 2 2
2 2 2
Also: Prüfe ob die erste Zelle in Spalte A in Datenblatt 2 vorhanden ist.
Wenn nein: dann gesamte Zeile aus Datenblatt 1 löschen.
So lange wiederholen, bis das Ende des Dokuments erreicht ist.
Ich komme einfach nicht weiter und würde mich über Beispiele für eine solche Lösung freuen.
Lieben Gruß
Tommy

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wenn Zelle nicht vorhanden, dann Zeile löschen
05.03.2016 16:04:19
ransi
HAllo Tommy
2 Hilfsspalten und dann einfach so:
Datenblatt1

 ABCD
1Daten1Daten2Daten3Daten4
2122WAHR
3522FALSCH
4222FALSCH

Formeln der Tabelle
ZelleFormel
D2=ZÄHLENWENN(Datenblatt2!D:D;A2&B2&C2)=0
D3=ZÄHLENWENN(Datenblatt2!D:D;A3&B3&C3)=0
D4=ZÄHLENWENN(Datenblatt2!D:D;A4&B4&C4)=0


Datenblatt2

 ABCD
1522522
2222222

Formeln der Tabelle
ZelleFormel
D1=A1&B1&C1
D2=A2&B2&C2


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Nach wahr filtern und löschen.
ransi

Anzeige
AW: Wenn Zelle nicht vorhanden, dann Zeile löschen
05.03.2016 16:28:25
Thomas
Hallo Ransi,
vielen Dank für deine schnelle Hilfe. Ich werde das später ausprobieren sobald ich die Datei habe.
Es handelt sich dabei um 5000 Zeilen in Datenblatt 1 und 3000 Zeilen in Datenblatt 2.
Macht das Excel mit? Wäre eine VBA Lösung grundsätzlich auch möglich?
Lieben Gruß
Tommy

404 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige