Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn im Wort ein Zahl vorkommt

Betrifft: Wenn im Wort ein Zahl vorkommt von: Hans Mansen
Geschrieben am: 11.08.2004 14:37:50

Hallo,

ich möchte eine Wenn Funktion so einrichten: Wenn in Zelle A1 eine Zahl vorkommt (egal an welcher Stelle), dann ... .

Für Hilfe bin ich sehr dankbar.

  


Betrifft: AW: Wenn im Wort ein Zahl vorkommt von: Jan
Geschrieben am: 11.08.2004 14:47:54

Hi Hans,


=WENN(ISTZAHL(B1);"Inhalt ist eine Zahl";"Wert ist keine Zahl")


Jan


  


Betrifft: AW: Wenn im Wort ein Zahl vorkommt von: Boris
Geschrieben am: 11.08.2004 14:49:30

Hi Hans,

als Array-Formel:

{=WENN(ANZAHL(TEIL(A1;SPALTE($1:$1);1)*1);"Ziffer vorhanden";"Fehlanzeige")}

{geschweifte Klammern} nicht eingeben, sondern Formeleingabe mit Strg-Shift-Enter abschließen. Das erzeugt sie.

Grüße Boris


  


Betrifft: AW: Wenn im Wort ein Zahl vorkommt von: Hans Mansen
Geschrieben am: 11.08.2004 15:32:20

Hallo,

danke für die Hilfe. Leider funktioniert die Formel von Jan nicht, wenn in der betreffenden Zelle nicht ausschließlich Zahlen stehen (z.B. "Test22"). Wie kann ich es lösen, damit trotzdem eine Zahl in der Zeichenfolge erkannt wird.

Danke


  


Betrifft: AW:Formel von Boris nehmen...oT von: HermannZ
Geschrieben am: 11.08.2004 15:59:46

...


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn im Wort ein Zahl vorkommt"