Summe nach Teilinhalt einer Zelle



Excel-Version: 97
nach unten

Betrifft: Summe nach Teilinhalt einer Zelle
von: Bernhard
Geschrieben am: 17.04.2002 - 14:06:56

Hallo X-ler,

ich muss Zellen summieren wenn die ersten 13 Stellen einer 15-stelligen Zahl übereinstimmen.
Bsp:

123456789999900 120
123456789999910 220
123456789999920 160
999995548777712 122

In Spalte A in den Zeilen 1-3 sind die ersten 13 Stellen identisch also sollen die Werte in Spalte B summiert werden.
Gewünschtes Ergebnis:

123456789999 500

Ist das in Excel möglich??

Gruß,
Bernhard


nach oben   nach unten

Re: Summe nach Teilinhalt einer Zelle
von: mathias r.
Geschrieben am: 17.04.2002 - 15:06:21

Mit einer Matrixformel Eingeben mit STRG+UMSCHALT+EINGABE =SUMME((LINKS(A1:A4;13))="1234567899999")*(B1:B4) Zitat aus Hans xlNews: "Matrixformeln sind ein Instrument zur Lösung komplexer Probleme mit Microsoft Excel und sind Tabellenblatt-, jedoch nicht Arbeitsmappenübergreifend einsetzbar. In vielen Fällen können sie als Ersatz für die unhandlichen Datenbankfunktionen eingesetzt werden. Matrixformeln sind in der Bearbeitungsleiste kenntlich an den sie umgebenden geschweiften Klammern und werden mit der Tastenkombination STRG+UMSCHALT+EINGABE ohne diese Klammern eingegeben."

nach oben   nach unten

Re: Summe nach Teilinhalt einer Zelle
von: Bernhard
Geschrieben am: 17.04.2002 - 15:18:40

Hallo Matthias, das ist ein guter Ansatz, leider handelt es sich um ca. 800 Datensätze wovon etwa 180 Schlüsselfelder in den ersten Stellen gleich sind. Daher suche ich eine etwas flexiblere Art der Auswertung. Aber danke für den Ansatz. Gruß, Bernhard

nach oben   nach unten

Re: Summe nach Teilinhalt einer Zelle
von: mathias r.
Geschrieben am: 17.04.2002 - 15:30:58

Und woran scheitert es dann? Der Bereich kann doch in der Formel auf 800 Datensätze erweitert werden. Es ist doch nur ein Beispiel das ich A1:A4 genommen habe. =SUMME((LINKS(A1:A800;13))="1234567899999")*(B1:B800) oder weißt du nicht wie die ersten 13 Zeichen derer Daten lauten wovon es die 180 Übereinstimmungen gibt?

nach oben   nach unten

Re: Summe nach Teilinhalt einer Zelle
von: Martin Beck
Geschrieben am: 17.04.2002 - 15:34:28

Hallo Bernhard, Annahme: Nummern in Spalte A, zu summierende Werte in Spalte B. Lege eine Hilfsspalte C an un gib in C1 die Formel =LINKS(A1; 13) ein. Kopiere die Formel soweit wie benötigt nach unten. Markiere B:C und erzeuge daraus eine Pivotabelle. Gruß Martin Beck

nach oben   nach unten

Re: Summe nach Teilinhalt einer Zelle
von: Bernhard
Geschrieben am: 17.04.2002 - 15:34:51

<> Genau das ist das Problem. Ich müsste bei dieser Formel erst eine Zuordungstabelle erstellen die die Suchkriterien enthält. Ich suche aber eine Lösung ähnlich der Teilergebnis-Funktion, nur das die Teilergebnisse nach 12 von 15 Stellen gebildet werden sollen. Kompliziert zu verstehen, oder??? Gruß, Bernhard

nach oben   nach unten

Re: Summe nach Teilinhalt einer Zelle
von: mathias r.
Geschrieben am: 17.04.2002 - 16:55:35

Also mit einer Datenbankabfrage käme da wohl eleganter ans Ziel... Hilft es weiter die jeweils x-Zeichen der Wert in eine extra Spalte anzeigen zu lassen, diese zu filtern (Duplikate ausblenden) und das Resultat(jeweils eine Zelle) dann in erst erwähnter Formel zu integrieren? Eindeutige Summe Anfangszeichen 123455 3000,12 345345 5234,34 545454 1323,23 etc.

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Spaltenbezeichnungen auf fortlaufenden Seiten "