Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

letzten Wert einer Spalte in Zelle einfügen

letzten Wert einer Spalte in Zelle einfügen
13.05.2009 10:50:10
Sascha
Hallo,
ich möchte ein Kassenbuch für meine Bedürfnisse schreiben. Bis jetzt kam ich da sehr gut ohne VBA mit zurecht. Im Grunde genommen habe ich für jeden Monat ein Tabellenblatt mit Einnahmen und Ausgaben und rechne damit den Bestand zusammen. Wenn ich nun aber in den nächsten Monat wechsel, soll der Bestand vom Vormonat in einer Zelle übernommen werden womit ich dann weiterrechnen kann. Bei meiner Tabelle ist in Spalte C der Bestand (ab C9) und soll nur dann ausgefüllt werden, sobald ein Eintrag bei Einnahmen oder bei Ausgaben vorgenommen wird. Ansonsten bleibt die entsprechende Zeile von Spalte C "" (leer).
Wie bekomme ich nun raus wo ich den letzten "gültigen" Wert (in Euro) herbekomme um diesen im Folgemonat weiterhin zu nutzen? Wenn möglich nicht in VBA (wäre aber notfalls auch egal).
Vielen Dank für Eure Mithilfe!

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
=VERWEIS(2;1/(G6:G65535 <>"");G6:G65535)
13.05.2009 11:06:47
robert
hi,
statt G deine spalte einsetzen
gruß
robert
AW: =VERWEIS(2;1/(G6:G65535 <>"");G6:G65535)
13.05.2009 11:09:48
Sascha
@robert
Lieben Dank, aber das funktioniert nur, wenn die Zellen wirklich leer sind, aber da ja in den Zellen eine Formel steht, geht das nicht wirklich.
AW: =VERWEIS(2;1/(G6:G65535 <>"");G6:G65535)
13.05.2009 11:12:02
Sascha
@robert
Was quatsch ich denn für ein blödes Zeug?
Das geht ausgezeichnet - Danke Dir vielmals ;-)))
kein problem-hauptsache es funkt-owT
13.05.2009 12:15:36
robert
AW: letzten Wert einer Spalte in Zelle einfügen
13.05.2009 11:06:54
Sascha
Nein sorry,
aber ich meine in der Spalte C9 steht der Startwert z.B. 12,23 Euro
und nun füllt sich die Spalte C bis meinetwegen C12 mit folgender Formel:
=WENN(ODER(GLÄTTEN(A10)"";GLÄTTEN(B10)"";GLÄTTEN(D10)"";GLÄTTEN(E10)"";GLÄTTEN(F10)""; GLÄTTEN(G10)"");C9+A10-B10;"")
wobei das fett geschriebene der wichtige Teil ist. In Spalte A stehen die Einnahmen und in Spalte B die Ausgaben.
Wenn ich nun auf das nächste Tabellenblatt wechsel, muss ich ja mit dem letzten "Gültigen" Wert aus der Spalte C fortfahren in meinem Beispiel den Wert aus C12 aber wie wenn in C13 steht:
=WENN(ODER(GLÄTTEN(A13)"";GLÄTTEN(B13)"";GLÄTTEN(D13)"";GLÄTTEN(E13)"";GLÄTTEN(F13)""; GLÄTTEN(G13)"");C12+A13-B13;"")
Anzeige

387 Forumthreads zu ähnlichen Themen


Hallo zusammen,
wie bekomme ich es hin, in eine Zelle "7 a" (7 Leerzeichen a) zu schreiben? Excel macht mir dann immer 7:00 AM daraus oder 0,29...
Danke
Anzeige

Guten Tag zusammen!
Bitte helft mir bei folgendem Problem:
In einer Userform habe ich eine ganze Reihe Textboxen, in die zum größten Teil Zahlen eingegeben werden.
Nun ist ja bekannt, dass beim Schreiben in Zellen der Inhalt der Textboxen als Text interpretiert wird. Mit der Anweisu...

Guten Tag zusammen!
Bitte helft mir bei folgendem Problem:
In einer Userform habe ich eine ganze Reihe Textboxen, in die zum größten Teil Zahlen eingegeben werden.
Nun ist ja bekannt, dass beim Schreiben in Zellen der Inhalt der Textboxen als Text interpretiert wird. Mit der Anweisu...
Anzeige

Halli Hallo,
ich bin ziemlicher Neuling in VBA. Daher würde ich euch bitten mir bei meiner Fragestellung zu helfen und zwar wie folgt: Ich möchte aus einer Tabelle aller Zellen kopieren, bis der Wert einer Zelle 0 annimmt. Diesen bestimten Bereich möchte ich in einer neuen Datei abspeichern...

hallo,
ich muß eine liste erstellen. die werte unten will ich nicht immer eingeben müssen, sondern nur dort wo ein wert stehen soll ein x machen. excel soll mir dann für jedes x den wert aus der zeile 2 der gleichen spalte eintragen. mache ich in eine zelle 2 x, dann muß der wert auch 2 mal...

Hi Leute
Ich habe hier diesen netten VBA Code geschrieben und leider wie solls auch anders sein kommt dauernd eine Fehlermeldung :)
CODE:
rowbeforeinteger = 2
Dim text As String
text = "=IF(" & epsoldcolumn & rowbeforeinteger & "=""x"";1;0)+IF(" & emailsoldco...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige