Marko starten bei Wert in Zelle



Excel-Version: Excel 2000
nach unten

Betrifft: Marko starten bei Wert in Zelle
von: Stephan B
Geschrieben am: 06.05.2002 - 11:17:08


Hallo liebe Forumer !

Ich habe In Zelle A1 einen Wert stehen der entweder
0 oder grösser entspricht !
Wenn der Wert grösser als 0 ist, so soll mein Marko
starten ! Kann mir jemand helfen ? Mit der Formel
=WENN(a1<>0;MEIN_MARKO;"") funktioniert leider nichts !

Gibt es eine andere Lösung, oder mache ich mit der Formel
etwas falsch ?


nach oben   nach unten

Re: Marko starten bei Wert in Zelle
von: Andreas
Geschrieben am: 06.05.2002 - 11:23:36

Hallo Stephan,

also Dein Makro in ein Modul etwa so:

Public Function MEIN_MAKRO()
MEIN_MAKRO = Range("A1").Value + 100
End Function

Und in die Zelle diese Formel:
=WENN(A1>0;MEIN_MAKRO();"")

Andere Möglichkeit wäre auch über das Worksheet_Change() Ereignis!

Viel Spaß,
Andreas

nach oben   nach unten

Re: Marko starten bei Wert in Zelle
von: Stephan B
Geschrieben am: 06.05.2002 - 12:02:46

HAllo Andreas

Danke für deine schnelle Hilfe !!!

Habe beide Varianten ausprobiert, doch leider ohne
Erfolg. Mache ich vielleicht etwas bei dem Markonamen
falsch ? Mein Marko nennt sich PERSONL.XLS!neu1. Was
muss ich eingeben damit die WENN-FORMEL bzw. Marko läuft ?

gruss Stephan


nach oben   nach unten

Re: Marko starten bei Wert in Zelle
von: Andreas
Geschrieben am: 06.05.2002 - 12:20:21

Hallo Stephan,

also wenn sich das Makro (Public Function) in einer anderen offenen Exceldatei befindet, dann so:
=WENN(A1>0;MappenName!MEIN_MAKRO();"")

Viel Spaß,
Andreas

nach oben   nach unten

Re: Marko starten bei Wert in Zelle
von: Stephan B
Geschrieben am: 06.05.2002 - 13:54:29

HAllo Andreas !

Ich bin irgendwie zu blöd für diese Formel !

Ich bekomme immer nach der Eingabe der Formel die
Meldung #Name? !!

Wo liegt der Fehler bei mir ? Muss das Makro immer
unter PublicFunction geschrieben werden? Ich habe ein
ganz gewöhnliches Marko aufgezeichnet, das in der
Formel gestartet werden sollte. Muss vielleicht
etwas in meiner Excelkonfiguration geändert werden?


nach oben   nach unten

Re: Marko starten bei Wert in Zelle
von: Andreas
Geschrieben am: 06.05.2002 - 14:23:46

Hallo Stephan,

also Du nutzt den Aufruf des Makros in einer Formel (WENN), es wird also ein Rückgabewert erwartet, deswegen Public Function MakroName()...

Diese Function muss aber auch vorhanden sein (d.h. Excelmappe in der sie steht, ist geöffnet!)
Probiere es doch mal mit meiner Function aus, die ich Dir vorhin gepostet habe!

Viel Spaß,
Andreas


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Marko starten bei Wert in Zelle"