Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählen mit Wert aus Zelle und nicht Zahl

Zählen mit Wert aus Zelle und nicht Zahl
Bunsenbrenner
Hallo,
bin neu hier, und habe schon ein Problem:
Ich will in einer Tabelle unter "Summe" einen Wert ermitteln, wobei die Zahl zwischen 0,00 und 250,00 liegt, wobei die Zahlen sich ändern können. Folgende Formeln funktionieren wunderbar
=ZÄHLENWENN(Alle!D2:D891;"größer0") neue Zelle =ZÄHLENWENN(Alle!D2:D891;"kleiner250") , jedoch würde ich gern sagen, nimm nicht den Zahl "größer0" sondern den Wert in Zelle A2, in der die 0 als Zahl steht, damit ggf., falls der Betrag sich einmal ändert, ich in der Tabelle nicht die Formeln sondern nur die Zahlen in A2 ändern/aktualisieren muss... Ich hoffe, ich konnte mich deutlich ausdrücken... Es wäre auch schick, wenn ich eine Formel hätte, in der stünde, dass Excel die Datensätze zählen soll, in denen die Zahlen zwischen A2 und B2 enthalten sind...
1 A B C
2 0,00 250,00 686
3 250,00 500,00 316
4 500,00 1.000,00 222
vielen Dank!

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: Zählen mit Wert aus Zelle und nicht Zahl
01.10.2010 13:18:56
JogyB
Hallo.
=ZÄHLENWENN($D$2:$D$891;">"&A2)-ZÄHLENWENN($D$2:$D$891;">"&B2)
Das nimmt jetzt alle Zahlen aus dem Intervall (A2,B2]
Da es so aussieht, als ob Du das für mehrere aufeinanderfolgende Intervalle machen willst: Bitte beachte, dass das Intervall auf einer Seite geschlossen sein muss und auf der anderen Seite offen sein muss (und zwar bei allen Intervallen gleich!), sonst lässt Du die Intervallgrenzen entweder weg oder zählst sie doppelt.
Gruß, Jogy
AW: Zählen mit Wert aus Zelle und nicht Zahl
01.10.2010 13:22:55
Rudi
Hallo,
=ZÄHLENWENN(Alle!D2:D891;">" &A2)
=summenprodukt((alle!D2:d800>=A2)*(alle!D2:d800<=B2))
Gruß
Rudi
Anzeige
AW: Zählen mit Wert aus Zelle und nicht Zahl
01.10.2010 15:30:34
Bunsenbrenner
danke schön und ein schönes Wochenende euch allen!!!!

360 Forumthreads zu ähnlichen Themen


Guten Morgen!
Ich hätte folgendes Problem: Ich erhalte automatisiert Exceltabellen, bei denen nicht alle Zellen einer Zeile gefüllt werden, wenn dort der Inhalt einer darüberliegenden Zeile stehen sollte. Zur Weiterverarbeitung muss ich aber diese Zellen mit den dazugehörigen Werten füllen....
Anzeige

hallo,
ich muß eine liste erstellen. die werte unten will ich nicht immer eingeben müssen, sondern nur dort wo ein wert stehen soll ein x machen. excel soll mir dann für jedes x den wert aus der zeile 2 der gleichen spalte eintragen. mache ich in eine zelle 2 x, dann muß der wert auch 2 mal...

Hallo,
kann ich den Inhalt einer Zelle im Windows Infobereich anzeigen lassen?
Ich habe eine VBA-Anwendung, die mir den Verarbeitungsstatus in einer Zelle anzeigt.
Weil die Verarbeitung sehr lange dauert möchte ich zwischendurch mit anderen Anwendungen arbeiten und unten rechts nebe...
Anzeige

Guten Morgen!
Ich habe z.B. in der Zelle A1 den Wert 5 stehen. Wird dieser Wert z.B. um die Zahl 3 verringert, dann soll der vorhandene Wert in der Zelle B1 um die Zahl 3 erhöht werden. Wie würde hier bitte eine Formellösung dafür lauten?
Danke
Josef

Hallo zusammen.
Ich habe in einer Zelle einen etwas längeren Text (mit Zahlen und Buchstaben). Ich würde jetzt gerne hieraus den Wert rausfiltern (in separate Spalte), der neben der Buchstabenkombination "AT" steht.
Hört sich einfach an. Da gibt es aber noch einige Sonderfälle.
Ich...

Hallo,
ich lauf gerade wieder mal mit einem Brett vorm Kopf rum und hoffe, mir kann einer hier helfen.
Ich habe in einer Zelle mehrere Werte stehen, die jeweils durch Semikolon getrennt sind (bis zu 15).
Wie kann ich per VBA eine Schleife erstellen, dass solange nach einem Wert gesu...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige