Anzeige
Archiv - Navigation
1280to1284
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wahrheitswerte in eine Zelle übernehmen

Wahrheitswerte in eine Zelle übernehmen
05.10.2012 16:57:38
Basti
Hallo zusammen.
Langsam beiß ich mir die Zähne aus.
Ich habe eine Arbeitsmappe erstellt. Dabei werden in Rabelle eins mittels Kontrollkästchen (7 Stk.) mehrer Ergebnisse geprüft (Tabelle 1; B1:B7. Es ist jeweils aus dieser Auswahl nur ein Wert "Wahr", der Rest "Falsch". Die Prüfung habe ich mt Zellbezug "Tabelle1; A1:A7" hinterlegt. Allerdings soll nun in "Tabelle 2" Zelle A1 der entsprechende Wert mit der Aussage "Wahr" aus B1:B7 übernommen werden. Es kann sich der Aussagewert aber auch mal ändern. Ich bekomm ich es einfach nicht hin. Kann mir vielleicht jemand weiterhelfen?
Danke vorab für eure Hilfe

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wahrheitswerte in eine Zelle übernehmen
05.10.2012 17:13:34
Uwe
Hallo Basti,
das würde ich einfach per Formel lösen (In Tabelle2 A1):
=INDEX(Tabelle1!A1:A7;VERGLEICH(WAHR;Tabelle1!B1:B7;0))
Ich hoffe ich habe Deine Beschreibung richtig gelesen!?
Gruß
Uwe
(:o)

AW: Wahrheitswerte in eine Zelle übernehmen
05.10.2012 17:34:20
Basti
Hallo Uwe.
Danke für die schnelle Antwort. Leider erscheint dann als Ergebnis #NV :-(

AW: Wahrheitswerte in eine Zelle übernehmen
05.10.2012 19:05:12
Uwe
Hallo Basti,
wenn in Tabelle1!B1:B7 irgendwo WAHR steht, kann das eigentlich nicht sein.
Verfolge doch mal mit dem "Formel Auswerten" - Tool, wo der Fehler liegt.
Als Excel-Profi müsstest Du die Formel eigentlich anpassen können.
Sonst lade mal ein Beispiel hoch.
Gruß
Uwe
(:o)

Anzeige
Wahrheitswert oder Text?
06.10.2012 08:15:32
Erich
Hi Basti,
könnte es sein, dass WAHR mal als Text, mal als Wahrheitswert verwendet wird?
Du schreibst ja nicht WAHR, sondern "Wahr". Das ist ein großer Unterschied.
Schau dir mal diese Tabelle an:
 ABCD
1FALSCHBB1BB3FALSCH
2FALSCHBB2#NVWAHR
3WAHRBB3#NV 
4FALSCHBB4  
5FALSCHBB5  
6    
7FALSCHBB1#NVWAHR
8FALSCHBB2BB3FALSCH
9WAHRBB3BB3 
10FALSCHBB4  
11FALSCHBB5  
12    
13FalschBB1#NVWAHR
14FalschBB2BB3FALSCH
15wahrBB3BB3 
16FalschBB4  
17WahrBB5  

Formeln der Tabelle
ZelleFormel
C1=SVERWEIS(WAHR;A1:B5;2;0)
D1=ISTTEXT(A1)
C2=SVERWEIS("WAHR";A1:B5;2;0)
D2=ISTLOG(A1)
C3=SVERWEIS("Wahr";A1:B5;2;0)
C7=SVERWEIS(WAHR;A7:B11;2;0)
D7=ISTTEXT(A7)
C8=SVERWEIS("WAHR";A7:B11;2;0)
D8=ISTLOG(A7)
C9=SVERWEIS("Wahr";A7:B11;2;0)
C13=SVERWEIS(WAHR;A13:B17;2;0)
D13=ISTTEXT(A13)
C14=SVERWEIS("WAHR";A13:B17;2;0)
D14=ISTLOG(A13)
C15=SVERWEIS("Wahr";A13:B17;2;0)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
in A1:A5 stehen Wahrheitswerte, in A7:A17 stehen Texte (sieht man in Spalte D).
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich

Anzeige
AW: Wahrheitswert oder Text?
06.10.2012 10:34:50
Basti
Hallo Erich, Hallo Uwe.
Also es ist nicht als Text definiert, es ist die Wahrheitsprüfung aus den Kontrollkästchen (aktiv=WAHR; inaktiv=FALSCH)

AW: Wahrheitswert oder Text?
06.10.2012 10:41:55
Hajo_Zi
Du hast es schon mit Typ() geprüft?
Gruß Hajo

Rückfragen
06.10.2012 12:27:57
Erich
Hi Basti,
ich gehe mal davon aus, dass du die SVERWEIS-Formeln aus meiner Beispieltabelle mal ausprobiert hast,
besonders die in den Zellen C1 und C2 (mal ohne, mal mit Gänsefüßchen).
Was kommt da bei welcher Formel raus?
Wie lautet deine Formel - bei der #NV rauskommt - genau?
Du schreibst, dass "es" (die Werte in Spalte A?) keine Texte, sondern Wahrheitswerte sind.
Hast du das geprüft mit ISTTEXT(), ISTLOG() oder TYP()? Was kam dabei raus?
Vielleicht könntest du mal eine kleine Beispieltabelle mit dem Fehler hochladen,
damit das Ratespiel ein Ende haben kann.
Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich
Anzeige

330 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige