Anzeige
Archiv - Navigation
1072to1076
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wert berechnen auch wenn in Zelle nichts steht

Wert berechnen auch wenn in Zelle nichts steht
13.05.2009 11:30:47
Sascha
Hallo,
ich habe in Spalte A die Einnahmen zu stehen, in Spalte B die Ausgaben und möchte mir in der Spalte C den Bestand anzeigen lassen. Nun möchte ich aber nur dann einen Wert anzeigen lassen, wenn in einer Zelle A? oder Zelle B? etwas eingetragen wird. Dieses Problem löse ich mit folgender Formel:
=WENN(ODER(GLÄTTEN(A30)"";GLÄTTEN(B30)"";C29+A30-B30;"")
Nur leider funktioniert das nicht, wenn der Benutzer eine Zeile in dem Bereich auslässt, weil Excel ja aus dieser Zeile in Spalte B einen Wert zum errechnen benötigt. Kann man Excel nicht dazu bringen eben den letzten Wert aus Spalte C zu nehmen?
Danke im Voraus.
Liebe Grüße Sascha

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wert berechnen auch wenn in Zelle nichts steht
13.05.2009 11:33:38
Ptonka
Hallo
=wenn(oder(A30="";B30="");"";C29+A30-B30)
Gruß,
Ptonka
AW: Wert berechnen auch wenn in Zelle nichts steht
13.05.2009 11:37:43
Sascha
Nein Ptonka, da wurde ich mißverstanden.
Wenn der Benutzer nun aber 2 Zeilen frei lässt oder 4 oder so dann greift die Formel wieder nicht.
AW: Wert berechnen auch wenn in Zelle nichts steht
13.05.2009 12:21:33
Harald
Na dann so:
Zelle C2: =SUMME($A$1:A2)-SUMME($B$1:B2)
Dann herumterkopieren der Formel in C3:Cxxx, je nachdem, wie weit Du es brauchst.
Annahme dabei: Die Zahlen fangen in A1 an.
Leerzeilen stören nicht
Gruß
Harald
immer letzte Summe berücksichtigen
13.05.2009 12:12:14
WF
Hi Sascha,
in C30:
=WENN(ODER(A30="";B30="");"";VERWEIS(2;1/(C$1:C29"");C$1:C29)+A30-B30)
runterkopieren
Salut WF
Anzeige
Frage-nicht wenn(und(... ?
13.05.2009 12:29:03
robert
hi WF,
habe deine formel ausprobiert, wenn i, A und B nichts, dann in C auch nichts.
wenn aber nur in B ein wert, dann auch kein saldo in C
mit Wenn(und(.... ist es meiner meinung nach korrekt-oder?
gruß
robert
ist auf jeden Fall logischer
13.05.2009 12:36:52
WF
Hi Robert,
da hab ich mich an die Ursprungsformel gehalten.
Vielleicht sollte das ja ausdrücken, dass es keine Einnahmen ohne Ausgaben geben kann und umgekehrt auch nicht ?
Salut WF
ist logischer-bin buchhalter in pension :-)
13.05.2009 13:09:40
robert
Hi WF,
mal sehen, wie es der user sieht...
gruß
robert
AW: Wert berechnen auch wenn in Zelle nichts steht
13.05.2009 13:28:49
robert
hi,
meinst du so ?
gruß
robert
https://www.herber.de/bbs/user/61785.xls
Anzeige
AW: Wert berechnen auch wenn in Zelle nichts steht
13.05.2009 14:05:57
Sascha
Hi Folks,
großes SORRY - ich hatte einen Absturz und der Administrator war bis eben zu Gange!
Ja, genau so meinte ich das Robert!!!
Es ist wirklich toll wie einem hier geholfen wird ! ! !
Ein großes DANKESCHÖN !
Grüße aus Berlin
gern geschehen-gruß aus wien :-) owT
13.05.2009 14:13:35
robert

324 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige