Microsoft Excel

Herbers Excel/VBA-Archiv

Funktion mit VBA in Arbeitsblatt schreiben | Herbers Excel-Forum


Betrifft: Funktion mit VBA in Arbeitsblatt schreiben von: Herbert
Geschrieben am: 28.07.2012 16:01:32

Hallo zusammen,

ich benötige mal wieder Eure Hilfe.
Ich will mit VBA eine sverweis-Funktion in ein Arbeitsblatt schreiben.

z. B.

Range("AJ2").Value = "=SVERWEIS(Z2;$AB$2:$AC$19;1;FALSCH)"

es klappt aber so nicht.

Wer hat die richtige Lösung???

Gruß
Herbert

  

Betrifft: AW: Funktion mit VBA in Arbeitsblatt schreiben von: Hajo_Zi
Geschrieben am: 28.07.2012 16:03:22

Hallo Herbert,

Range("AJ2").FormulaLocal= "=SVERWEIS(Z2;$AB$2:$AC$19;1;FALSCH)"

GrußformelHomepage


  

Betrifft: AW: Funktion mit VBA in Arbeitsblatt schreiben von: Herbert
Geschrieben am: 28.07.2012 16:42:06

Hallo Hajo,

vielen Dank.

Das klappt prima!!!

Gruß
Herbert


  

Betrifft: AW: Funktion mit VBA in Arbeitsblatt schreiben von: Hajo_Zi
Geschrieben am: 28.07.2012 16:44:02

Hallo Herbert,

in VBA sollte man Formel in englisch schreiben, dann nur Forumla.
Überstzt bekommst Du deine Formel, wenn Du eine Internatioanle Makrovorlage einfügst und dorthin die Formel kopierst.

Gruß Hajo


Beiträge aus den Excel-Beispielen zum Thema "Funktion mit VBA in Arbeitsblatt schreiben"