Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zelle auswerten nach Komma

Zelle auswerten nach Komma
walter
Hallo Fachexperten und Frauen,
ich habe in einer Zelle Daten stehen, die mit einem Komma getrennt sind.
z.b. A10 steht: 12,3,5,2,1000 (es könnte auch mal eine3.5 also mit Punkt
drin stehen.
nun möchte ich in a11= 12
in a12= 3 u.s.w.
stehen haben also die Werte immer bis zum Komma.
Herzlichen Dank im Voraus für Unterstützung,
mfg walter kr
mit VBA
04.07.2010 17:15:56
Tino
Hallo,
hier mit einem VBA Code
Sub Split_TxT()
Dim varAr, strTempText$, lngMaxRow&
strTempText$ = Replace(Range("A10"), ".", ",")
varAr = Split(strTempText$, ",")
lngMaxRow& = Cells(Rows.Count, 1).End(xlUp).Row
If lngMaxRow& > 10 Then
Range("A11").Resize(lngMaxRow - 10).ClearContents
End If
If IsArray(varAr) Then
Range("A11").Resize(UBound(varAr) + 1) = Application.Transpose(varAr)
End If
End Sub
Gruß Tino
oder mit einer eigenen Funktion.
04.07.2010 17:31:13
Tino
Hallo,
kommt in ein normales Modul.
Function Split_TxT(strText$, ByVal iIndex As Integer)
Dim varAr, strTempText$

iIndex = iIndex - 1
Split_TxT = ""
strTempText$ = Replace(Range("A10"), ".", ",")
varAr = Split(strTempText$, ",")

If IsArray(varAr) Then
    If Ubound(varAr) >= iIndex Then
        Split_TxT = varAr(iIndex)
        If Split_TxT Then _
            Split_TxT = Split_TxT * 1
    End If
End If

End Function
In Excel kannst Du es wie eine Formel verwenden.
 A
1012,1,5,9,8.1598
1112
121
135
149
158
161598
17 

Formeln der Tabelle
ZelleFormel
A11=Split_TxT(A10;ZEILE(A1))
A12=Split_TxT(A11;ZEILE(A2))
A13=Split_TxT(A12;ZEILE(A3))
A14=Split_TxT(A13;ZEILE(A4))
A15=Split_TxT(A14;ZEILE(A5))
A16=Split_TxT(A15;ZEILE(A6))
A17=Split_TxT(A16;ZEILE(A7))

Gruß Tino
Anzeige
Leider Fehler
04.07.2010 17:50:28
walter
Hallo Tino,
der eingegebene Name ist ungültig.
Meine Gesamtwerte stehen in M4
und die erste Aufteilung in O4, P4 u.s.w.
mfg walter kr
wie geschrieben, der Code in ein Modul oT.
04.07.2010 17:53:06
Tino
Hallo Tino, einwandfrei !!! --)))
04.07.2010 19:32:31
walter
Hallo Tino,
jetzt klappt alles !
Danke,
mfg walter kr
Danke Tino für den Makro Tip aber
04.07.2010 17:42:19
walter
Hallo Tino,
wie kann ich die nächsten aufteilen ?
mfg walter kr
wo stehen die nächsten
04.07.2010 17:52:01
Tino
Hallo,
wenn man wüste wo die nächsten stehen, kann dies im Code eingebaut werden.
Oder verwende die zweite Variante mit der Funktion.
Gruß Tino
Habe die 2.Variante genommen -)
04.07.2010 19:33:28
walter
Zellwerte nach Komma trennen
04.07.2010 17:24:00
NoNet
Hallo Walter,
Hier 2 Möglichkeiten :
Falls die Zellen B10:J10 frei sind :
- Markiere A10
- Menü "Daten - Text in Spalten - Getrennt - Komma - OK"
  => die Zellen sind nun auf A10:E10 aufgeteilt
- Markiere A10:E10
- Kopiere diese Zellen (z.B. Strg+C)
- Klicke A10 ein
- Menü "Bearbeiten - Inhalte einfügen - Werte - Transponieren - OK"
  => die Werte stehen nun in A10:A14
Oder : Per Funktion (Bitte in A11:B12 eingeben und dann A12:B12 nach unten kopieren) :
AB
10
11
12
13
14
15
16
17
18
19
20

Formeln der Tabelle
Zelle Formel 
A11   =LINKS($A$10;B11-1) 
A12   =WENN(ISTZAHL(B12);TEIL($A$10;B11+1;B12-B11-1);WENN(ISTZAHL(B11);RECHTS($A$10;LÄNGE($A$10)-B11);"")
A13   =WENN(ISTZAHL(B13);TEIL($A$10;B12+1;B13-B12-1);WENN(ISTZAHL(B12);RECHTS($A$10;LÄNGE($A$10)-B12);"")
A14   =WENN(ISTZAHL(B14);TEIL($A$10;B13+1;B14-B13-1);WENN(ISTZAHL(B13);RECHTS($A$10;LÄNGE($A$10)-B13);"")
A15   =WENN(ISTZAHL(B15);TEIL($A$10;B14+1;B15-B14-1);WENN(ISTZAHL(B14);RECHTS($A$10;LÄNGE($A$10)-B14);"")
A16   =WENN(ISTZAHL(B16);TEIL($A$10;B15+1;B16-B15-1);WENN(ISTZAHL(B15);RECHTS($A$10;LÄNGE($A$10)-B15);"")
A17   =WENN(ISTZAHL(B17);TEIL($A$10;B16+1;B17-B16-1);WENN(ISTZAHL(B16);RECHTS($A$10;LÄNGE($A$10)-B16);"")
A18   =WENN(ISTZAHL(B18);TEIL($A$10;B17+1;B18-B17-1);WENN(ISTZAHL(B17);RECHTS($A$10;LÄNGE($A$10)-B17);"")
A19   =WENN(ISTZAHL(B19);TEIL($A$10;B18+1;B19-B18-1);WENN(ISTZAHL(B18);RECHTS($A$10;LÄNGE($A$10)-B18);"")
A20   =WENN(ISTZAHL(B20);TEIL($A$10;B19+1;B20-B19-1);WENN(ISTZAHL(B19);RECHTS($A$10;LÄNGE($A$10)-B19);"")
B11   =SUCHEN(",";$A$10) 
B12   =WENN(ISTZAHL(SUCHEN(",";$A$10;B11+1));SUCHEN(",";$A$10;B11+1);"") 
B13   =WENN(ISTZAHL(SUCHEN(",";$A$10;B12+1));SUCHEN(",";$A$10;B12+1);"") 
B14   =WENN(ISTZAHL(SUCHEN(",";$A$10;B13+1));SUCHEN(",";$A$10;B13+1);"") 
B15   =WENN(ISTZAHL(SUCHEN(",";$A$10;B14+1));SUCHEN(",";$A$10;B14+1);"") 
B16   =WENN(ISTZAHL(SUCHEN(",";$A$10;B15+1));SUCHEN(",";$A$10;B15+1);"") 
B17   =WENN(ISTZAHL(SUCHEN(",";$A$10;B16+1));SUCHEN(",";$A$10;B16+1);"") 
B18   =WENN(ISTZAHL(SUCHEN(",";$A$10;B17+1));SUCHEN(",";$A$10;B17+1);"") 
B19   =WENN(ISTZAHL(SUCHEN(",";$A$10;B18+1));SUCHEN(",";$A$10;B18+1);"") 
B20   =WENN(ISTZAHL(SUCHEN(",";$A$10;B19+1));SUCHEN(",";$A$10;B19+1);"") 

Gruß, NoNet
gegen    2:1
Anzeige
Danke NoNet --))
04.07.2010 17:45:52
walter
Danke NoNet für
die Tips, werde gleich testen.
mfg walter kr
AW: Formel gibt es bei excelformeln.de
04.07.2010 19:37:18
walter
Guten Abend Erich,
auch Dir, danke für die Hilfe,
wewrde dies ebenfalls nachher testen,
mfg walter kr

339 Forumthreads zu ähnlichen Themen


Guten Morgen!
Ich hätte folgendes Problem: Ich erhalte automatisiert Exceltabellen, bei denen nicht alle Zellen einer Zeile gefüllt werden, wenn dort der Inhalt einer darüberliegenden Zeile stehen sollte. Zur Weiterverarbeitung muss ich aber diese Zellen mit den dazugehörigen Werten füllen....
Anzeige

hallo,
ich muß eine liste erstellen. die werte unten will ich nicht immer eingeben müssen, sondern nur dort wo ein wert stehen soll ein x machen. excel soll mir dann für jedes x den wert aus der zeile 2 der gleichen spalte eintragen. mache ich in eine zelle 2 x, dann muß der wert auch 2 mal...

Hallo,
kann ich den Inhalt einer Zelle im Windows Infobereich anzeigen lassen?
Ich habe eine VBA-Anwendung, die mir den Verarbeitungsstatus in einer Zelle anzeigt.
Weil die Verarbeitung sehr lange dauert möchte ich zwischendurch mit anderen Anwendungen arbeiten und unten rechts nebe...
Anzeige

Guten Morgen!
Ich habe z.B. in der Zelle A1 den Wert 5 stehen. Wird dieser Wert z.B. um die Zahl 3 verringert, dann soll der vorhandene Wert in der Zelle B1 um die Zahl 3 erhöht werden. Wie würde hier bitte eine Formellösung dafür lauten?
Danke
Josef

Hallo zusammen.
Ich habe in einer Zelle einen etwas längeren Text (mit Zahlen und Buchstaben). Ich würde jetzt gerne hieraus den Wert rausfiltern (in separate Spalte), der neben der Buchstabenkombination "AT" steht.
Hört sich einfach an. Da gibt es aber noch einige Sonderfälle.
Ich...

Hallo,
ich lauf gerade wieder mal mit einem Brett vorm Kopf rum und hoffe, mir kann einer hier helfen.
Ich habe in einer Zelle mehrere Werte stehen, die jeweils durch Semikolon getrennt sind (bis zu 15).
Wie kann ich per VBA eine Schleife erstellen, dass solange nach einem Wert gesu...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige