Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

ZÄHLENWENN mit Wert aus dritter Zelle

ZÄHLENWENN mit Wert aus dritter Zelle
Jan
Hallo,
eigentlich ganz simpel vermutlich. Ich habe ein Datenblatt zur Dienst/Personalerfassung und möchte die genommenen Urlaubstagen, Fortbildungstagen etc. über das Gesamtjahr und bis zum heutigen Tag ausgeben.
In zwei Zeilen habe ich jeweils Beginn und Ende des Arbeitsverhältnissen der x Mitarbeiter, in einer Spalte die Daten von 1.1. bis 31.12. In der Matrix, die sich dazwischen aufspannt, dann die jeweiligen Schichten und sonstigen Eintragungen, das ist aber eigentlich nebensächlich.
Über =(VERGLEICH(D2;$C40:$C404;0)) suche ich die Beginn- und Enddaten in der Zeitleiste und wandele sie in Ziffern von 1 bis 365 um, dasselbe mache ich mit dem heutigen Datum per =(VERGLEICH(HEUTE();$C40:$C404;0)) So kann ich gut Differenzen errechnen, z.B. Kollege D hat 2011 nur 72 Tage für uns gearbeitet, Kollege C die vollen 365 Tage.
Das eigentliche Problem:
Wenn ich über das Gesamtjahr die genommenen Fortbildungstage einsehen will, frage ich natürlich
=ZÄHLENWENN(D40:D404;"xf"), wobei "xf" das Kürzel für Fortbildung ist.
Wie aber geht das von 1.1. bis heute?
=ZÄHLENWENN(D40:"D"&(VERGLEICH(HEUTE();$C40:$C404;0));"xf") funktioniert nicht, und =ZÄHLENWENN(D40:"D"&B2;"xf") auch nicht, wenn ich die obige Formel bspw. in Zelle B2 parke. Und das, obwohl beide Schreibweisen in einer einzelnen Zelle ohne ZÄHLENWENN sehr wohl richtig ausgegeben werden.
Wo habe ich den Denkfehler drin? Oder geht das einfach bei ZÄHLENWENN und Co. nicht?
Danke schon mal & Grüße,
Jan

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: ZÄHLENWENN mit Wert aus dritter Zelle
06.05.2011 08:47:02
hary
Hallo Jan
meinst Du so?

Tabellenblattname: Tabelle1
 

B

C

D

1

3

01.05.2011

 

2

 

02.05.2011

xf

3

 

03.05.2011

xf

4

 

04.05.2011

 

5

 

05.05.2011

xf

6

 

06.05.2011

 

7

 

07.05.2011

 

8

 

08.05.2011

xf

9

 

09.05.2011

 


Benutzte Formeln:
B1: =SUMMENPRODUKT((C1:C21

gruss hary
Anzeige
AW: ZÄHLENWENN mit Wert aus dritter Zelle
06.05.2011 09:04:17
Jan
Hm, damit habe ich zwar den Vergleich ganz umsonst gemacht - aber warum kompliziert, wenn es auch einfach geht. ;-)
Vielen Dank!
Dann kann ich mich ja für die Gesamtstatistik statt dem Heute() auch auf die Zelle beziehen, in dem das Enddatum des Kollegen verzeichnet ist, oder? Und was wäre, wenn es ein Praktikum von 1.3. bis 1.6. macht? Geht das auch mit zwei einschränkenden Argumenten?
AW: ZÄHLENWENN mit Wert aus dritter Zelle
06.05.2011 09:11:54
hary
Hallo Jan

Tabellenblattname: Tabelle1
 

B

C

D

E

F

1

03.05.2011

11.05.2011

3

01.05.2011

 

2

 

 

 

02.05.2011

xf

3

 

 

 

03.05.2011

xf

4

 

 

 

04.05.2011

ad

5

 

 

 

05.05.2011

xf

6

 

 

 

06.05.2011

 

7

 

 

 

07.05.2011

ad

8

 

 

 

08.05.2011

xf

9

 

 

 

09.05.2011

 

10

 

 

 

10.05.2011

 

11

 

 

 

11.05.2011

 

12

 

 

 

12.05.2011

xf

13

 

 

 

13.05.2011

 

14

 

 

 

14.05.2011

 


Benutzte Formeln:
D1: =SUMMENPRODUKT((E1:E21>=B1)*(E1:E21

gruss hary
viel Auswahl an Formeln schau mal hier:
http://www.excelformeln.de/formeln.html
Anzeige
AW: ZÄHLENWENN mit Wert aus dritter Zelle
06.05.2011 09:21:56
Jan
Super, vielen Dank!
Diesen Summenprodukt ist ja ziemlich praktisch... trotz des furchtbaren Namens. ;)
AW: ZÄHLENWENN mit Wert aus dritter Zelle
06.05.2011 09:56:56
hary
Hallo Jan
kanst Du auch mit heute kombinieren. Wenn z.B. C leer ist wird heute genommen.

Tabellenblattname: Tabelle1
 

A

B

C

D

E

F

1

meyer

03.05.2011

05.05.2011

2

01.05.2011

 

2

schulze

03.05.2011

 

3

02.05.2011

xf

3

 

 

 

 

03.05.2011

xf

4

 

 

 

 

04.05.2011

ad

5

 

 

 

 

05.05.2011

xf

6

 

 

 

 

06.05.2011

xf

7

 

 

 

 

07.05.2011

ad

8

 

 

 

 

08.05.2011

xf

9

 

 

 

 

09.05.2011

 

10

 

 

 

 

10.05.2011

 

11

 

 

 

 

11.05.2011

 

12

 

 

 

 

12.05.2011

xf

13

 

 

 

 

13.05.2011

 


Benutzte Formeln:
D1: =SUMMENPRODUKT(($E$1:$E$21>=B1)*($E$1:$E$21 D2: =SUMMENPRODUKT(($E$1:$E$21>=B2)*($E$1:$E$21

gruss hary
Anzeige

384 Forumthreads zu ähnlichen Themen


Hallo Zusammen,
ich habe eine Inputbox, über die eine Passwortabfrage gesteuert wird. Leider ist das Passwort im Eingabefeld zu sehen. Ist es möglich den Text z.B. in der Schriftart "Wingdings" zu formatieren, oder
die Schriftfarbe in weiss, damit das Passwort nicht mehr zu sehen ist?
Anzeige

Hallo,
ich hätte eine allgemeine Frage zum Zugriff auf Access-Datenbanken.
Welche Zugriffsmethode auf eine Access-DB würdet Ihr generell empfehlen: ADO oder DAO?
Gibt es in der Praxis Vor- oder Nachteile für die eine oder andere Zugriffsweise?
Vielen Dank für Euere Meinungen und...

Hallo und einen schönen guten Tag
Bitte um Hilfe.
Offset aber wie?
Ich möchte 2 List- oder Combofelder aus einer UserForm mit Werten der aktiven Zeile füllen, die ich dann mit Hilfe der List oder Combobox ändere.
z.B.
A5 oder A6 oder A150 u.s.w.
B5 oder B6 oder B150 u....
Anzeige

Guten Abend
ich möchte gerne wissen, wieviele ODER-Fragen in eine WENN Funktion eingebunden werden können.
folgendes Beispiel:
Grundfunktion: wenn (X=wahr,dann A1 sonst B1)
meine Frage: wenn (oder(C1={"x";"y"};D1={"x";"y"});A1;B1)
C1 ist eine ODER Frage die ich, wie ich w...

Hallo,
ich habe eine etwas komplexere Wenn-Oder Formel erstellt, welche ich über VBA in eine Zelle einfügen möchte.
Formel in E2:
=WENN(ODER(LINKS(D2;2)="M1";LINKS(D2;2)="M2";LINKS(D2;2)="M3";LINKS(D2;2)="M4";LINKS(D2;2)="M5"); LINKS(D2;1);WENN(LINKS(D2;2)="NM";LINKS(D2;2);WENN(LIN...

Hallo werte Profis
Irgendwie raff ich es heute nicht
Habe eine Spalte mit Artikel Nummern. Jeweils das erste Zeichen ist = Produkte Typ.
A976164
A980602
B181645
B491942
F199587
F215047
F224410
G224410
F232634
Ich möchte nun anhand des ersten Zeich...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige