HERBERS Excel-Forum - das Archiv

Thema: Zählewenn oder Wenn-dann-Bed. | Herbers Excel-Forum

Zählewenn oder Wenn-dann-Bed.
torge

Hallo zusammen,
ich habe zu folgendem Beispiel eine Frage:
Ich möchte die Kosten der Tabelle "Kostenbasis" in der Ausgabetabelle in dem jeweiligen Monate und in der dazugehörigen Zeile angezeigt bekommen, wenn in der Eingabetabelle bspw. im Monat Jan eine 1 steht. D. h. die Kosten sollen von der zeitl. Verteilung in die Ausgabetelle übergeleitet. Mit welcher Formel ist zu arbeiten ? "Zählewenn oder Wenn-dann-Bed? Oder gibt es noch elegantere Lösungen
Vorab schon mal vielen Dank für die Antworten. Leider ist die Formatierung etwas verrutscht. Die Zahlen (1;2;3;) in der Eingabetabelle sollen direkt unter den Monaten stehen.
Ausgabetabelle
Jan Feb Mar Apr
Planung 1
Durchf 2
Prüfung 3
Eingabetabelle
Jan Feb Mar Apr
1 1 1 1
2 2 2
3 3 3
Kostenbasis
1 Planung = 1 Mio. €
2 Durchf. = 2 Mio. €
3 Prüfung = 1 Mio. €

AW: Zählewenn oder Wenn-dann-Bed.
IngGi

Hallo torge,
ich bin mir nicht sicher, ob ich dich richtig verstanden habe. Du möchtest die Kosten auf die Monate aufteilen, für die eine 1, 2 bzw. 3 in der Eingabetabelle vorhanden ist? Dann zum Beispiel so:
 ABCDE
1Ausgabetabelle    
2 JanFebMarApr
3Planung0,25 Mio. €0,25 Mio. €0,25 Mio. €0,25 Mio. €
4Durchf.0,67 Mio. €0,67 Mio. €0,67 Mio. € 
5Prüfung0,33 Mio. €0,33 Mio. €0,33 Mio. € 
6     
7Eingabetabelle    
8 JanFebMarApr
9Planung1111
10Durchf.222 
11Prüfung333 
12     
13Kostenbasis    
141Planung1,0 Mio. €  
152Durchf.2,0 Mio. €  
163Prüfung1,0 Mio. €  

Formeln der Tabelle
ZelleFormel
B3=WENN(ISTFEHLER(SVERWEIS(B9;$A$14:$C$16;3;0)/ZÄHLENWENN($B9:$E9;"="&$A14));"";SVERWEIS(B9;$A$14:$C$16;3;0)/ZÄHLENWENN($B9:$E9;"="&$A14))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
In C14:C16 bzw. B3:E5 stehen reine Zahlen in den Zellen. "Mio. €" wird über ein benutzerdefiniertes Zahlenformat erzeugt!
Gruß Ingolf
Bitte Beispieldatei hochladen
NoNet

Hallo torge,
so ganz schlau wird man aus der Darstellung dieser Tabelle leider nicht.
Lade doch bitte mit dem Link Hier gehts zum File-Upload eine kleine Beispieldatei hoch und poste uns die URL.
Damit lässt sich Dein Anliegen vermutlich viel einfacher verstehen und auch schneller lösen...
Gruß, NoNet