Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählenwenn mit getrennten Zellen

Zählenwenn mit getrennten Zellen
petra
hallo,
ich bräuchte mal eure hilfe...
und zwar würde ich gerne bereiche zählen lassen, die größer als 0 sind...
dabei liegen die Zellen die durchsucht werden sollen nicht direkt aneinander, sondern mit erheblichen zellenabständen.
also zum beispiel
zelle b9
zelle b59
zelle b109
usw.
insgesamt müssen 12 zellen durchgezählt werden...
die zellen mit ";" auflisten funktioniert leider nicht.
kann mir jemand sagen wie das geht?
gibt es eine Möglichkeit, einen Bereich zu definieren.
Danke für eure Hilfe
lg
petra
AW: Zählenwenn mit getrennten Zellen
11.09.2009 12:25:25
Rudi
Hallo,
für das Bsp.:
=SUMMENPRODUKT((B1:B1000>0)*(REST(ZEILE(B1:B1000);50)=9))
Gruß
Rudi
AW: Zählenwenn mit getrennten Zellen
11.09.2009 12:41:34
petra
Hi Rudi,
also irgendwas zählt er...aber nicht das richtige ergebnis...
ich habs mal auf mein konkretes beispiel umgeschrieben
= SUMMENPRODUKT((G9:G735 > 0)*(REST(ZEILE(G9:G735);66)=9))
Die erste Zahl fängt bei G9 an
dann folgt
g75
g141
g207
g273
g339
g405
g471
g537
g603
g669
g735
Die jeweiligen zellen können Zahlen , Buchstaben oder auch komplett leere Zellen sein. Die Formel soll mir jetzt die anzahl an Zellen nennen, die einen Wert größer 0 aufweisen. Leerzellen oder Zellen mit Buchstaben sollen nicht berücksichtigt sein.
die Formel die ich von dir hab, gibt mir werte. aber es sind nicht die werte, die ich dort gerne hätte.
was mache ich falsch?
LG + Danke dir schon mal für deine hilfe
petra
Anzeige
AW: Zählenwenn mit getrennten Zellen
11.09.2009 12:43:07
JogyB
Hi.
Das geht mit der Formel von Rudi nicht, die setzt ein System voraus (das es in Deinem ersten Beispiel gab). Das mußt Du dann so machen, wie ich beschrieben habe... außer da hat noch jemand eine schönere Lösung (mir fällt aber leider keine ein).
Gruss, Jogy
AW: Zählenwenn mit getrennten Zellen
11.09.2009 12:49:08
petra
hmm, mit deiner formel kommen die gleichen werte raus wie bei rudi...
komisch...
der zählt leere zellen genauso mit...
wie kann ich das verhindern?
danke schon mal für eure hilfe
lg petra
AW: Zählenwenn mit getrennten Zellen
11.09.2009 13:01:02
JogyB
Hi.
Hmm, also unter Excel 2003 zählt meine Formel zählt keine leeren Zellen, 2007 habe ich nicht.
Die Zellbezüge hast Du hoffentlich angepaßt?
Gruss, Jogy
Anzeige
AW: Zählenwenn mit getrennten Zellen
11.09.2009 13:24:42
Rudi
Hallo,
evtl. so:
= SUMMENPRODUKT(ISTZAHL(G9:G735)*(G9:G735 > 0)*(REST(ZEILE(G9:G735);66)=9))
Gruß
Rudi
AW: Zählenwenn mit getrennten Zellen
11.09.2009 15:16:46
petra
perfekt!!!!!!
so klappt es....
Danke dir!!!
lg
petra
AW: Zählenwenn mit getrennten Zellen
11.09.2009 15:33:39
petra
hmm, funktioniert doch leider nicht so wie gedacht...
hab noch mal geschaut woran es liegen könnte.
die leeren zellen sind eigentlich nicht wirklich leer. da sind formeln enthalten, die unter bestimmten voraussetzungen die Zelle mit "" leer erscheinen lassen.
dadurch zählt er quasi "falsch"
gibts noch ne andere möglichkeit?
lg
petra
AW: Zählenwenn mit getrennten Zellen
11.09.2009 12:29:52
JogyB
Hi.
Wenn da kein System dahintersteckt, dann kannst Du das so machen:
=SUMME(--(B9>0);--(B17>0);--(B21>0);--(B26>0))
Ist natürlich aufwendig, aber um das aufzählen der Zellen kommst Du eh nicht rum.
Gruss, Jogy
Anzeige

349 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige