Microsoft Excel

Herbers Excel/VBA-Archiv

Bruch oder ganze Zahlen anderer Zelle ausrechnen

Betrifft: Bruch oder ganze Zahlen anderer Zelle ausrechnen von: alin
Geschrieben am: 04.08.2014 14:59:44

Gibt es eine Formel für Excel, mit der ich eine ganze Zahl oder einen Bruch einer anderen Zelle ausrechnen lassen kann?
Diese ist dort als Text formatiert. Wenn die Zelle leer ist, soll nichts ausgerechnet werden.
Es soll so sein als würde ich in der "Zielzelle" ein Gleichheitszeichen vor der Zahl, auf die ich mich beziehe, stehen.

D.h.

A1: 2
B1: 2

A2: 1/4
B2: 0,25

A3: (leer)
B3: (leer)

Wie lautet die Formel für B?

Danke für die Hilfe

  

Betrifft: AW: Bruch oder ganze Zahlen anderer Zelle ausrechnen von: {Boris}
Geschrieben am: 04.08.2014 15:17:19

Hi,

bin nicht sicher - aber vielleicht suchst Du das hier: http://www.excelformeln.de/formeln.html?welcher=238

VG, Boris


  

Betrifft: AW: Bruch oder ganze Zahlen anderer Zelle ausrechnen von: alin
Geschrieben am: 04.08.2014 17:39:46

Danke!

Ja, genau!
Wie lautet jetzt der Befehl, wenn ich will, dass die Zelle nur dann ausgerechnet wird, wenn sie Text enthält, also ungleich "" ist?

=WENN($L$3="";"";"=Ergebnis")
?


  

Betrifft: in Deinem Fall sollte eine reine Formel reichen... von: neopa C (paneo)
Geschrieben am: 04.08.2014 17:30:28

Hallo alin,

... wie Du es beschreibst gibt es bei Dir als Nichtziffer ja nur "/". Oder?

In dem Fall folgende Formel in B1:
=WENN(A1="";"";0+WENNFEHLER(LINKS(A1;FINDEN("/";A1)-1)/TEIL(A1;FINDEN("/";A1)+1;99);A1))
und nach unten kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: in Deinem Fall sollte eine reine Formel reichen... von: alin
Geschrieben am: 04.08.2014 17:49:15

Hi Werner,

Als Nichtziffer gibt es nur eine leere Zelle.
Fehlt in deiner Formel nicht die Funktion Ergebnis?


  

Betrifft: die Formel ergibt das Ergebnis ... von: neopa C (paneo)
Geschrieben am: 04.08.2014 17:57:21

Hallo alin,

... oder was meinst Du mit Deiner Frage?
Alternativ zu der Formel in B1 (nach unten kopieren) kannst Du auch die in C1 nutzen. Sollten dazu noch Fragen sein, dann meinerseits mehr Morgen. ich gehe jetzt erst einmal offline.

 ABC
122=2
21/40,25=0,25
3   
45/80,625=0,625
5   

Formeln der Tabelle
ZelleFormel
B1=WENN(A1="";"";0+WENNFEHLER(LINKS(A1;FINDEN("/";A1)-1)/TEIL(A1;FINDEN("/";A1)+1;99); A1))
C1=WENN(A1="";"";WENNFEHLER("="&LINKS(A1;FINDEN("/";A1)-1)/TEIL(A1;FINDEN("/";A1)+1;99); "="&A1))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: die Formel ergibt das Ergebnis ... von: alin
Geschrieben am: 05.08.2014 11:01:47

Danke,

die Formel für B1 funktioniert wie gewünscht.
...okay und was muss ich tun, damit in B1 ganze Zahlen ohne Dezimalstelle und das Ergebnis eines Bruchs mit nur 2 Dezimalstellen angezeigt wird?

Vielen Dank für die Hilfe


  

Betrifft: dann einfach noch RUNDEN() ... von: neopa C (paneo)
Geschrieben am: 05.08.2014 11:30:03

Hallo alin,

... die Ganzzahl wird bereits jetzt richtig angezeigt. Um für den Bruch, die Dezimalzahl immer mit zwei Nachkommastellen anzuzeigen, einfach noch RUNDEN().

Also in B1 =WENN(A1="";"";0+WENNFEHLER(RUNDEN(LINKS(A1;FINDEN("/";A1)-1)/TEIL(A1;FINDEN("/";A1)+1;99);2);A1))

Gruß Werner
.. , - ...


  

Betrifft: ...und eine Fkt ERGEBNIS gibt's nich, ... von: Luc:-?
Geschrieben am: 04.08.2014 18:02:02

…nur TEILERGEBNIS, falls du das (bei deinem Xl-Level zu erinnern) meinst, Alin,
aber die hat hiermit nichts zu tun!
Gruß, Luc :-?

Besser informiert mit …


 

Beiträge aus den Excel-Beispielen zum Thema "Bruch oder ganze Zahlen anderer Zelle ausrechnen"